IONIC BUILD IOS Does Nothing and just drop to next line

Your system information:

Cordova CLI: 5.3.3
Gulp version: CLI version 3.9.0
Gulp local:
Ionic Version: 1.1.0
Ionic CLI Version: 1.7.7
Ionic App Lib Version: 0.6.3
ios-deploy version: 1.8.2
ios-sim version: 5.0.3
OS: Mac OS X El Capitan
Node Version: v5.0.0
Xcode version: Xcode 7.1 Build version 7B91b

Zeeshans-MBP:my-reddit zeeshansabri11$ ionic build ios
Zeeshans-MBP:my-reddit zeeshansabri11$ ionic emulate ios
Zeeshans-MBP:my-reddit zeeshansabri11$

Nothing happening. I was getting some errors and check with my Udemy instructor and I have been told that I installed my Node using sudo so I have uninstall complete node, ionic and cordova and then reinstall it now I’m not getting those errors but now Build and Emulate command not doing anything at all.

I have seen similar post on forum but that seems old and recommending downgrade to some really old version not sure if it’s still valid.

Btw: I’m new with all Ionic, cordova and node so please go easy on me :smile:

Make sure you include the platforms by

ionic platform add ios

And then rerun the build command.

HI DaDanny,

Thanks for the suggestion, not that new :wink: Yes I have done that even I tried removing the iOS build and re-add it but still the same.

Just checking, we all make silly mistakes :smile:

So no errors are output in the terminal? What happens when you try ionic run ios?

I’m having the same issue after running:

$ npm update

Both ionic run ios and ionic emulate ios fail too.

Sorry, I just made a duplicate post and just after posting I saw this in suggested topics. I’ve given a little more detail:

@zeeshansabri Did you happen to run the same command as me today?

@DaDanny @zeeshansabri

I beleive the issue is Node 5.0.0. Works when I downgrade to 4.2.1. Instructions as per

$ npm install -g n 
$ n 4.2.1

I was finding commands like $bower install was doing the same thing which made me think of it.

He Bensinclair,

No I didn’t run npm update. It’s stopped working since I uninstall and reinstall all of my node, ionic etc


Hi Bensinclair,

Thanks for coming back to me, I have tried

npm install -g n

and it’s automatically installed n@2.0.2 when I tried

nam install -g n 4.2.1 

it gives me a 404 error on

what I’m doing wrong. BTW, I tried on 2.0.2

ionic build iOS 

and result was same :confused:

Reinstalling node most likely reinstalled npm to the latest version.

That command you’ve run is incorrect. To run multiple commands at once, use && to separate each command. E.g:

npm install -g n && n 4.2.1

If you still get errors try running it with sudo in front:

sudo npm install -g n && sudo n 4.2.1


Thank you man. it worked… yay :smiley:

What about Node v7, I’m having the same problem there. Do I need to downgrade it?

Probably not. I’m using node 7.7.2 without build problems so I doubt node is the issue.