Ionic 4 App on Android 4.4.2 not working

Hi, I’m trying to deploy an app I’m building over and android mobile device which is a rather bit old. Its using the version 4.4.2 (Samsung S4 Mini) which based on the ionic official documentation should be supported.

When I manually install the generated debug build apk file on the device, it correctly installs it but when I try opening it, then the app stucks and doesn’t bootstrap (splash screen remains). The strange thing is that when I try installing it on another mobile phone using Android 7.X it works fine! (also checked on 8.X & 9.X)


After reviewing a while, I ran my app from my VS code terminal to the mobile plugged in by USB cable and the same error occurred. This time I inspected the console log on Chrome’s Dev Tool to check for any errors, and indeed I got 2 errors.

The first one:

Uncaught TypeError: pre,template,textarea,script,style is not iterable

Reviewing this error I found two posts (link at the bottom) that suggested to uncomment some imports from the polyfills.ts from my project regarding older web versions. I did this, build and ran again and the error is gone but the app still doesn’t bootstrap. Now my console log looks like:

My Ionic info:


   ionic (Ionic CLI)             : 4.9.0 (C:\Users\rodrigomartinezjr\AppData\Roaming\npm\node_modules\ionic)
   Ionic Framework               : @ionic/angular 4.0.0
   @angular-devkit/build-angular : 0.12.4
   @angular-devkit/schematics    : 7.2.1
   @angular/cli                  : 7.3.0
   @ionic/angular-toolkit        : 1.3.0


   cordova (Cordova CLI) : 8.1.2 (cordova-lib@8.1.1)
   Cordova Platforms     : not available
   Cordova Plugins       : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 2.3.0, (and 12 other plugins)


   NodeJS : v10.14.1 (C:\Program Files\nodejs\node.exe)
   npm    : 6.7.0
   OS     : Windows 10

Post Links: