Ionic app not loading on Android 4.4.2


#1

Hi All,

I am using:

Your system information:

Cordova CLI: 6.4.0 
Ionic Framework Version: 3.0.1
Ionic CLI Version: 2.1.18
Ionic App Lib Version: 2.1.9
Ionic App Scripts Version: 1.3.0
ios-deploy version: Not installed
ios-sim version: Not installed
OS: macOS Sierra
Node Version: v6.9.4
Xcode version: Xcode 8.3.2 Build version 8E2002

I have built an app with:

ionic build android

This builds the relevant apk file, that I can install to an Android devise.

I have tried a number of devises successfully:

Samsung Galaxy S7 with Android 6.0.1
Samsung Galaxy S5 with Android 5

However, when I try install it on the following, it seems to just hang when I launch the app:

Samsung Galaxy Tab with Android 4.4.2

I have added an alert to the top of the constructor in app.components.ts, but this does not get fired on the Android 4.4.2 devise.

If anyone can offer any ideas I would appreciate it.


#2

What does your inspector makes out of this when running chrome://inspect?


#3

When I run the app in Chrome:

ionic serve

It runs perfectly, with no errors in the console.

(Is that what you were asking?)


#4

No sorry. You should really inspect the device itself to know what’s going on. You can do that by enabling usb debugging on your device and then inspect it through chrome, when going to inspect://chrome . Do you know what I mean? Here’s an excellent tut about the chrome://inspect


#5

Yes that makes sense. My problem unfortunately is my MacBook doesn’t have USB port (just Thunderbolt 3) to attach with my Android devise. I will see if I can install an Android Emulator with 4.4.2. Do you think that’s a good idea?


#6

Off course. I’m pretty sure there’s something going on which prevents your app from booting and I’m guessing that you’ll see some error logs when inspecting your device. Does it run on iOS emulator though? That you could inspect with safari developer tools, then you don’t need to install an Android Emulator but you could debug it with an iOS emulator first.


IONIC App not working on Android 4.4.2 & 4.2.2
#7

Yes, it does work with the iOS emulator. I am busy installing Andy, and will try get it running on Android 4.4.2. Will chrome://inspect/#devices be able to connect to an emulator?


#8

@richardmarais how did you resolved the issue of,

ionic-app-not-loading-on-android-4-4-2


#9

https://ionic.zone/debug/remote-debug-your-app#android