How to bring ionic-v1 app up to date with firebase?


#1

I’m maintaining a legacy Ionic-v1 app. It is using firebase 2.3.2. Since Firebase recently announced that it will no longer be supporting SDK 2.x, I need to bring it forward.

  1. Can I use the latest firebase 5.x package?
    This git repo by Dale Nguyen looks like Ionic-v1 is compatible with at least firebase 4.6.1.

  2. What about AngularFire?Will AngularFire 2.3.0 work with firebase 5.x?
    The consensus seems to be that it’s useful, but not required. These migration docs seem to suggest that I should stick with AngularFire, and not go with AngularFire2 (that’d be an Angular 2+ thing). Again, the git repo by Dale Nguyen suggests that it might.

  3. What are good resources or examples for me to look at?

Thanks for your help!


#2

I’m also interested in this topic. On our side we have been using Firebase 3.6.0 (rc3) and AngularFire 2.1.0 for a while now and everything is working great. We also have GeoFire at version 4.1.2. If any of that can help. Cheers