Flebox dont work after ionic build android


#1

I 'm trying d migrate an application but when compiling the styles applied to flebox not work.

System information

Cordova CLI: 6.0.0
Ionic CLI Version: 1.7.14
Ionic App Lib Version: 0.7.0
OS: Windows 10
Node Version: v5.5.0
Android Studio 1.5

Ionic lab

The error see now in ios dont show before

##HTML##

`

    <ion-content>
        
        <div id="login">
        
        <div class="logo-unicesar">
            <img src="img/logo2.png" class="">
        </div>

        <div class="list list-inset">

            <div class="text-center">
                <p>{{respuesta}}</p>
            </div>

            <label class="item item-input">
                <i class="icon ion-person placeholder-icon"></i>
                <input type="text" placeholder="Usuario">
            </label>

            <label class="item item-input">
                <i class="icon ion-key placeholder-icon"></i>
                <input type="password" placeholder="Contraseña">
            </label>

            <button class="button button-block button-balanced">
                INGRESAR
            </button>

        </div>
            
    </div>
        
    <div class="bar bar-footer bar-balanced">
        <div class="title">UNICESAR</div>
    </div>`

##CSS##

`#login{
     height: 100%;
 }

.logo-unicesar{
     height: 40%;
     margin: auto;
     display: flex;
     display: -webkit-flex;
     justify-content: center;
     justify-content: 
     align-content: center;
     align-items: center;
 }

 .formulario{
      margin: auto;
      display: flex;
  }

 .text-center{
       margin: auto;
      display: flex;
      justify-content: center;
      align-items: center;    
  }

 .text-center p{
    height: 25px;
        padding-bottom: 5px;
        color: firebrick;
        font-weight: 500;
  }

##Android View##

`


#2

Hi! So what version of android are you testing against? If it’s older android, it may not support that version of flexbox

http://caniuse.com/#feat=flexbox

What you would need to do is expand the css to use the various different version of flexbox


#3

Adding to that, you might want to look the Crosswalk Project to replace the webview for better standards support.


#4

Maybe this is the reason, but how configurate the android studio compile for android version > 4.0


#5

How implement that in my project


#6

Sorry forgot to provide that bit of information:


There are pros and cons in using it, so look it over carefully and see it will provide a possible fix for you