Error when trying npm install ionic@1.3.5


#1

Hello everyone - if anyone can help that would be appreciated

When I run npm install ionic@1.3.5 I get

npm ERR! code ETARGET
npm ERR! notarget No matching version found for i@0.3.2
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn’t exist.
npm ERR! notarget
npm ERR! notarget It was specified as a dependency of ‘bxmktauth’

However, in package.json I don’t see anything specifying this ? Am I looking in the wrong place.

{
“name”: “bxmktauth”,
“version”: “1.1.1”,
“description”: “bxmktAuth: An Ionic project”,
“dependencies”: {
"@ionic/cloud": “^0.16.0”,
"@ionic/cloud-angular": “^0.11.0”,
“bluebird”: “^3.4.7”,
“cordova-ios”: “4.5.4”,
“cordova-plugin-compat”: “~1.1.0”,
“cordova-plugin-contacts”: “~2.2.1”,
“cordova-plugin-device”: “^1.1.7”,
“cordova-plugin-file”: “^5.0.0”,
“cordova-plugin-file-transfer”: “^1.7.0”,
“cordova-plugin-inappbrowser”: “^1.7.2”,
“cordova-plugin-ionic-webview”: “^1.1.16”,
“cordova-plugin-network-information”: “^1.3.4”,
“cordova-plugin-splashscreen”: “^4.1.0”,
“cordova-plugin-statusbar”: “^2.3.0”,
“cordova-plugin-whitelist”: “^1.3.3”,
“gulp”: “^3.5.6”,
“gulp-concat”: “^2.2.0”,
“gulp-minify-css”: “^0.3.0”,
“gulp-rename”: “^1.2.0”,
“gulp-sass”: “^2.0.4”,
“ionic-plugin-keyboard”: “^2.2.1”,
“phonegap-plugin-push”: “^2.1.0”
},
“devDependencies”: {
“bower”: “^1.3.3”,
“gulp-util”: “^2.2.14”,
“preen”: “^1.2.0”,
“shelljs”: “^0.3.0”
},
“cordovaPlugins”: [
“cordova-plugin-device”,
“cordova-plugin-console”,
“cordova-plugin-whitelist”,
“cordova-plugin-splashscreen”,
“cordova-plugin-statusbar”,
“ionic-plugin-keyboard”
],
“cordovaPlatforms”: [
“ios”,
{
“platform”: “ios”,
“version”: “”,
“locator”: “ios”
}
],
“cordova”: {
“plugins”: {
“cordova-plugin-ionic-webview”: {},
“cordova-plugin-contacts”: {
“CONTACTS_USAGE_DESCRIPTION”: " "
},
“cordova-plugin-compat”: {},
“phonegap-plugin-push”: {
“SENDER_ID”: “XXXXXXXXX”
},
“cordova-plugin-device”: {},
“cordova-plugin-whitelist”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-statusbar”: {},
“cordova-plugin-network-information”: {},
“cordova-plugin-inappbrowser”: {},
“cordova-plugin-file-transfer”: {},
“ionic-plugin-keyboard”: {}
},
“platforms”: [
“ios”
]
}
}


#2

Seems i develop unpublished by mistake 0.3.2

https://www.npmjs.com/package/i

:frowning:


#4

Thank you for your reply. I installed i@0.3.3 but I still get the same error


#5

How did you end up resolving this? I’m currently stuck on 1.3.1 and running into the same issue