Getting exception when installing ionic cli

#1

elio@elio-HP-15-Notebook-PC: npm install -g ionic
npm ERR! code ETARGET
npm ERR! notarget No matching version found for @ionic/cli-framework@1.0.3
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn’t exist.
npm ERR! notarget
npm ERR! notarget It was specified as a dependency of ‘ionic’
npm ERR! notarget

npm ERR! A complete log of this run can be found in:
npm ERR! /home/elio/.npm/_logs/2018-08-06T23_12_53_207Z-debug.log

#2

What node and npm versions are you using?

#3

node -v -> v10.8.0
npm -v -> 6.2.0

Thanks!

#4

This version exists, and there is even a newer one: https://www.npmjs.com/package/@ionic/cli-framework

Maybe just try again?

#5

I did this now:

npm i @ionic/cli-framework

but then I dont have access globally to use the Ionic command…

I also did npm i -g @ionic/cli-framework
It was installed but cant access to Ionic using the command line

#6

@ionic/cli-framework is just a component of the global ionic package. You should not manually install it, it will come with ionic.

#7

So I guess this is not helping to me… because I cant install ionic directly, so I cant do anything for 2 days having the pro xD

#8

Should I feel bad now that I, a community member just like you, tried helping you or what do you want to achieve with this comment?

One thing you could try: Uninstall your node, install nvm (or nvm-windows if you are on Windows), install a new node (which includes npm) with this, then install ionic and cordova again. This quite often fixes pretty strange issues like yours.

#9

No no Sujan! my comment was not in that way! thanks to answer me! Well, I changed the session, I could install it from another session :|, and now I came back to the main session and it is there… this is the tipical weird issue, something internal for sure!

Thanks to be in my side helping me and giving me ideas! Sujan:star_struck:

1 Like
#10

Great you fixed it. Node and npm are sometimes just weird - especially on Windows.