ERROR: Unable to emulate app on platform ios, again


#1

Hello, I see the same error in this page but after reading achievement and not try to fix it all, can someone help?

** BUILD SUCCEEDED **

2014-06-09 22:48:12.334 ios-sim[1195:507] stderrPath: /Users/ivanloreiro/WebStormProjects/myApp/platforms/ios/cordova/console.log
2014-06-09 22:48:12.335 ios-sim[1195:507] stdoutPath: /Users/ivanloreiro/WebStormProjects/myApp/platforms/ios/cordova/console.log
Session could not be started: Error Domain=DTiPhoneSimulatorErrorDomain Code=2 “Simulator session timed out.” UserInfo=0x7f990162e510 {NSLocalizedDescription=Simulator session timed out.}
Error: /Users/ivanloreiro/WebStormProjects/myApp/platforms/ios/cordova/run: Command failed with exit code 1
at ChildProcess.whenDone (/usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:131:23)
at ChildProcess.EventEmitter.emit (events.js:98:17)
at maybeClose (child_process.js:753:16)
at Process.ChildProcess._handle.onexit (child_process.js:820:5)
ERROR: Unable to emulate app on platform ios. Please see console for more info.
Exiting.

thanks, I’m a little desperate because I was doing my first test


#2

I use this solution (link) but its only work width xcode, no width terminal, it’s normal?


#3

Did you install the ios-sim package? It’s required to start the iOS simulator from cmd line.

Install it like this:
$ npm install -g ios-sim


#4

I think if I have it installed, run it yet again and I got the same error.

HW004-042: myApp root # ios-sim --version
1.9.0

The emulator error still appears.


#5

I stumbled upon the same symptom half an hour ago, i. e. containing the string “NSLocalizedDescription=Simulator session timed out.”. The culprit in my case was the firewall, because I couldn’t confirm the rule fast enough, which Little Snitch suggested.

So, could it be something on the network layer which causes your timeouts?