Emulate ios: Session could not be started [ERROR]

Hello everyone! I’m trying to emulate my application on ios but nothig works for me. I’ve been searching for two days about the error and all workarounds i’ve found doesn’t work for me. I’m running OSX Yosemite, Xcode 6.1.1, Cordova 4.2.0, Ionic 1.3.8, Ios-Sim 3.1.1. This is the ouput:


2015-03-01 20:07:08.576 ios-sim[5970:3191481] stderrPath: /path/to/myapp/platforms/ios/cordova/console.log
2015-03-01 20:07:08.577 ios-sim[5970:3191481] stdoutPath: /path/to/myapp/platforms/ios/cordova/console.log
Session could not be started: Error Domain=DTiPhoneSimulatorErrorDomain Code=2 "Simulator session timed out." UserInfo=0x7ff3d370ff10 {NSLocalizedDescription=Simulator session timed out.}
Error: /path/to/myapp/platforms/ios/cordova/run: Command failed with exit code 1
    at ChildProcess.whenDone (/usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:135:23)
    at ChildProcess.emit (events.js:98:17)
    at maybeClose (child_process.js:766:16)
    at Process.ChildProcess._handle.onexit (child_process.js:833:5)

I really don’t know what to do. I already tried all worarounds I’ve found on internet: change files permissions, running as sudo, reset settings of emulator, open xcode before emulating my app, reinstalling cordova, etc, etc. No one works. Hope you can help me, guys! If you need further information, please let me know.

Thank you in advance!

It’s a long shot but have you tried updating ios-sim?

Yes, it’s up to date. Even I reinstalled ios-sim and nothing happens :frowning:

I’ve had this happen before, it seems to be an issue with the ios-simulator.

If you start the simulator before hand, you shouldn’t have this issue.

# start the simulator
$ ios-sim start

Thanks for the tip. But simulator always started with the error. Anyway, I tried running ios-sim start and after that doing ionic emulate ios, throws same error. Honestly I don’t know what to do. I’ve tried everything.

Thank you anyway!