Error compiling on IOS - Mac OS X El Capitan

I am having problems compiling on IOS (Mac OS X EL CAPITAN), getting this error.

IonicDeploy.m:345:27: error: no visible @interface for ‘UIView’ declares the selector ‘loadRequest:’

Cordova CLI: 6.0.0
Gulp version: CLI version 3.9.0
Gulp local: Local version 3.9.0
Ionic CLI Version: 1.7.13
Ionic App Lib Version: 0.6.5
ios-deploy version: 1.8.4
ios-sim version: 5.0.6
OS: Mac OS X El Capitan
Node Version: v4.2.6
Xcode version: Xcode 7.2 Build version 7C68

– UPDATED – SOLVED INSTALL IOS-DEPLY, bad syntax, it is --unsafe-perm
I tried to insall ios-deploy without success…

sudo npm install -g ios-deploy --unsafe-perms=TRUE --allow-root

Exception: The loaded com.apple.CoreSimulator.CoreSimulatorService job does not match our expectations: versionOfLoadedJob: (null), our version: 201.3

Any help will be appreciated, I am not expert on XCode.

This just started happening to me as well. The solution you provided in your update doesn’t make much sense to me - I don’t have my npm global packages in a dir owned by root so I don’t need the --unsafe-perms=TRUE or the --allow-root

Perhaps there was something else that changed?

I’m seriously pulling my already thinning hair out

I get the same error since yesterday, any help would be appreciated :relaxed:

Thanks in advance !

Hey guys, there is a pull request waiting who fix this issue:

cordova-ios@4.x has deprecated some features (see https://github.com/apache/cordova-ios/blob/master/RELEASENOTES.md)

I hope it helps. Bye !