Cordova-plugin-firebase issues with ios

I have created iOS build for my ionic4 app having Cordova version 9.0.0. When I installed cordova-plugin-firebase and build the code with ionic cordova buld ios command, build failed with following error :
The following build commands failed:
CompileC /Users/devbis365/Library/Developer/Xcode/DerivedData/DriversApp-hcwntjbscgtzpvdriulszbasewep/Build/Intermediates.noindex/DriversApp.build/Debug-iphonesimulator/DriversApp.build/Objects-normal/x86_64/FirebasePlugin.o /Users/devbis365/Documents/DriveraAPP/testDrivers/Drivers/platforms/ios/DriversApp/Plugins/cordova-plugin-firebase/FirebasePlugin.m normal x86_64 objective-c com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)

Any ideas.??

Please thy this Plugin: https://ionicframework.com/docs/native/firebase-x

Tried the same plugin and got error… Any solution to fix this error…?

Exactly the same Error with the other Plugin?

Not Same error. I installed both the plugins mentioned in link successfully. But when I am trying to add platform folder for iOS it failed with following error:
Failed to install ‘cordova-plugin-firebasex’: Error: pod: Command failed with exit code 31

Appreciate your help… :+1:

Have you uninstalled the normal Firebase Plugin?

Yes… I have uninstalled normal firebase plugin

Also getting following messages along with the error :
[!] Found multiple specifications for Crashlytics (3.14.0):

  • /.cocoapods/repos/cocoapods/Specs/3/6/0/Crashlytics/3.14.0/Crashlytics.podspec.json
  • /.cocoapods/repos/trunk/Specs/3/6/0/Crashlytics/3.14.0/Crashlytics.podspec.json

[!] Found multiple specifications for GoogleSignIn (5.0.2):

  • /.cocoapods/repos/cocoapods/Specs/d/4/0/GoogleSignIn/5.0.2/GoogleSignIn.podspec.json
  • /.cocoapods/repos/trunk/Specs/d/4/0/GoogleSignIn/5.0.2/GoogleSignIn.podspec.json

[!] Found multiple specifications for GoogleTagManager (7.1.2):

  • /.cocoapods/repos/cocoapods/Specs/9/5/6/GoogleTagManager/7.1.2/GoogleTagManager.podspec.json
  • /.cocoapods/repos/trunk/Specs/9/5/6/GoogleTagManager/7.1.2/GoogleTagManager.podspec.json
    at ChildProcess.whenDone (/node_modules/cordova-common/src/superspawn.js:135:23)

Not sure these are the warning or errors. Any solution…?