'Cordova/CDVViewController.h' file not found in Xcode 7.1 beta


#21

Awesome. Thanks @shazron!


#22

Unbelievable.
Every day theres something else,
I now have to do about 10 different hacks to get the system running and even then it only kind of works.
The way things stand now Ionic and ios is one huge hack, I’m trying to keep my cool, but I have never seen a more horrible contraption for a developer.


#23

Life saver. Thanks guys!


#24

Great!!! Many thanks


#25

It is possible to set via command line as well. I’m triggering the xcodebuild command from a shell script, where you can do:

xcodebuild HEADER_SEARCH_PATHS="\$(TARGET_BUILD_DIR)/usr/local/lib/include \$(OBJROOT)/UninstalledProducts/include \$(OBJROOT)/UninstalledProducts/\$(PLATFORM_NAME)/include \$(BUILT_PRODUCTS_DIR)"

Notice that I had to escape $

The paths I’ve taken from the latest in

https://github.com/apache/cordova-ios/blob/master/bin/templates/scripts/cordova/build.xcconfig

#26

Thanks @Sikavica! For anyone running xcodebuild through gulp, be sure to double escape the dollar signs: \\$(TARGET_BUILD_DIR...


#28

I’m using gradle to build my app and my build.gradle produces this issue now that I upgraded to 7.1. I run an ionic build ios followed by the xcodebuild HEADER_SEARCH_PATHS="\$(TARGET_BUILD_DIR)/usr/local/lib/include \$(OBJROO... command line fix listed above. I still receive the CDVViewController.h file not found. It seems like setting the HEADER_SEARCH_PATH param does not stick when done via command line. Do I need to set the headers inside the ionic build ios call somehow?


#29

It works!! Thanks a lot!!


#30

Worked for me :smile:


#31

Hey guys ! You don’t have to do it anymore with cordova-ios@3.9.2 :+1:


#32

I have it ios@3.9.2 and got the error, shazron answer fix it too!


#33

Lifesaver thank you! It works


#34

Thank you. This worked for me too. I really appreciate your help.


#35

Thanks so much for this, I added to the same line with a space in between and that did the trick!


#36

Cool man that works for me too.you are a life saver .Thanks a lott:smile:


#37

I have the stable version of Xcode 7.1.1 and this problem still occurs even after I added $(OBJROOT)/UninstalledProducts/$(PLATFORM_NAME)/include in the Build Settings.


#38

Thank a lot… This is working in xCode 7.1 Stable version


#39

Updating Xcode to 7.2 and Updating Cordova fixed this issue for me.


#40

None of the above worked for me, but I found a way eventually:

Version Information:

Cordova 5.4.1
Xcode 7.1.1 (7B1005)
Node 5.2.0
Ionic 1.7.11

  1. Run this in your terminal: cordova platform update ios
  2. Open your project in Xcode
  3. Go to Preference -> Locations -> Advanced
  4. Choose “Unique” as the option for Build Location
  5. Product -> Clean
  6. Product -> Build

For good karma, I also added “$(OBJROOT)/UninstalledProducts/$(PLATFORM_NAME)/include” to the header search paths but that alone didn’t fix the issue.


#41

Thank you it work fine!