'Cordova/CDVViewController.h' file not found


I was trying to ARCHIVE ios app but unfortunately after much efforts with google, I still cannot solve this problem.

  1. I can build and run properly with emulate devices.
  2. Only trying archive give me the problem ‘Cordova/CDVViewController.h’ file not found
  3. I already tried below ways to solve the problem:
  • Remove the CordovaLib & add it again (Linked Libs and so on…)
  • Clean & Build many times both CordovaLib & My Project
  • Set Derived Data to Unique (in default, XCode 7.1 Beta)
  • Default Header Search Path is correctly with values:

Does anyone experience this problem and can give me any advice…

  • latest ionic 1.6.4
  • latest cordova 5.3.1
  • XCode 7.1 beta

Thank you.

Hi @lhviet, I’m having the same problem using the same versions.
I was able to archive my app using XCode 6. Like you said, running on iOS 9 emulators on Xcode 7.1 beta works fine, it’s only the archive that shows this issue.

1 Like

Me too having the same problem… I tried all the above options. Even download the new Xcode version. but still having the issue while Archiving.

same problem here, here is my config:

Cordova CLI: 5.3.3
Gulp version: CLI version 3.9.0
Gulp local: Local version 3.9.0
Ionic Version: 1.1.0
Ionic CLI Version: 1.7.7
Ionic App Lib Version: 0.6.3
ios-deploy version: 1.8.2
ios-sim version: 5.0.3
OS: Mac OS X El Capitan
Node Version: v0.12.2
Xcode version: Xcode 7.1 Build version 7B91b

Solved thanks to @shazron

Add this line to your Build Settings -> Header Search Paths:

Don’t replace the existing line that looks similar, that is still needed to be backwards compatible with Xcode 7 and Xcode 6.4.

This probably had something to do with tvOS, I reckon – Apple had to separate the archive intermediates by platform for universal builds.

Hi, I have another problem. I was working perfectly with Xcode 7.0.X but when I updated to Xcode 7.1 my application didn’t work, When I added the platform (ios or android) it made the platform but like a new project, changes that I made in the project does not do in the platforms, Can someone help me please. What can I do? Im using El Capitan 10.11