CocoaPods Version Outdated In Latest macOS Build

When building my latest version of the app (through appflow) I received this error during the npx cap sync process

[!] GoogleAppMeasurement requires CocoaPods version >= 1.10.2, which is not satisfied by your current version, 1.10.0.

I am running the “latest” version of macOS in my build configurations

Build Stack
macOS - 2020.11

And previous topics have listed this as a dependency of the build configuration used. For now I’m attempting to find the specific capacitor plugin that was updated and downgrade the version.

    "@capacitor-community/facebook-login": "^3.1.1",
    "@capacitor-community/firebase-analytics": "1.0.0",
    "@capacitor/app": "^1.0.0",
    "@capacitor/core": "3.0.0",
    "@capacitor/device": "^1.0.2",
    "@capacitor/ios": "^3.0.0",
    "@capacitor/keyboard": "^1.0.2",
    "@capacitor/splash-screen": "^1.0.0",

I am assuming one of these minor version upgrades has GoogleAppMeasurements as a transitive dependency which is causing the error. I’ll report back if I figure it out.

I am also facing the same issue. Please let us know in case you find a solution.


This looks like this could be an issue with using an older version of the Cocoapods. You can try to build with our new build stack MacOS 2021.09 which has the latest cocoapods release (1.11.2).

Give it a try and If you are facing any further issues, I would encourage you to contact the Appflow support for further assistance.


1 Like