CocoaPods Error Illformed requirement `"$IOS_FIREBASE_AUTH_VERSION"`

When I try to install the pods by “pods install” I keep getting the following error:

Illformed requirement "$IOS_FIREBASE_AUTH_VERSION"

The podfile looks like this:

platform :ios, ‘11.0’

workaround to avoid Xcode caching of Pods that requires

Product -> Clean Build Folder after new Cordova plugins installed

Requires CocoaPods 1.6 or newer

install! ‘cocoapods’, :disable_input_output_paths => true

def capacitor_pods

Automatic Capacitor Pod dependencies, do not delete

pod ‘Capacitor’, :path => ‘…/…/node_modules/@capacitor/ios’
pod ‘CapacitorCordova’, :path => ‘…/…/node_modules/@capacitor/ios’
pod ‘CordovaPlugins’, :path => ‘…/capacitor-cordova-ios-plugins’
pod ‘CordovaPluginsStatic’, :path => ‘…/capacitor-cordova-ios-plugins’
pod ‘CordovaPluginsResources’, :path => ‘…/capacitor-cordova-ios-plugins’

Do not delete


target ‘App’ do
pod ‘FirebaseCore’
pod ‘Firebase/Analytics’
pod ‘Firebase/Messaging’

Add your Pods here


Can anybody help me with this?

The latest version of cocoapods is installed --> 1.10.x

These version of capacitor is installed:

├── @capacitor/android@2.4.6
├── @capacitor/cli@2.4.6
├── @capacitor/core@2.4.6
├── @capacitor/ios@2.4.6

1 Like