CocoaPods could not find compatible versions for pod "Firebase/Auth":

Hey guys, I had to step away from my project for a few months for funding to secure and today i got to get back into to prep a demo and I am having a hard time getting a build going I keep hitting this error. Im not a backend guy just dude who makes things look pretty for some context.

Analyzing dependencies
[!] CocoaPods could not find compatible versions for pod "Firebase/Auth":
  In Podfile:
    CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.2, which depends on
      Firebase/Auth (~> 6.32.2)

    Firebase/Auth

CocoaPods could not find compatible versions for pod "Firebase/CoreOnly":
  In Podfile:
    CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.2, which depends on
      Firebase/Analytics (~> 7.0.0) was resolved to 7.0.0, which depends on
        Firebase/Core (= 7.0.0) was resolved to 7.0.0, which depends on
          Firebase/CoreOnly (= 7.0.0)

    CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.2, which depends on
      Firebase/Auth (~> 6.32.2) was resolved to 6.32.2, which depends on
        Firebase/CoreOnly (= 6.32.2)

Any insight to this would be awesome

Did a ionic build

Then npx cap sync and ran into similar error

[!] CocoaPods could not find compatible versions for pod "Firebase/Auth":
  In Podfile:
    CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.2, which depends on
      Firebase/Auth (~> 6.32.2)

    Firebase/Auth

CocoaPods could not find compatible versions for pod "GoogleUtilities/Environment":
  In Podfile:
    CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.2, which depends on
      Firebase/Auth (~> 6.32.2) was resolved to 6.32.2, which depends on
        Firebase/CoreOnly (= 6.32.2) was resolved to 6.32.2, which depends on
          FirebaseCore (= 6.10.2) was resolved to 6.10.2, which depends on
            GoogleUtilities/Environment (~> 6.7)

    CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.2, which depends on
      GoogleUtilities (~> 7.2.2) was resolved to 7.2.2, which depends on
        GoogleUtilities/Environment (= 7.2.2)

Updated CLI to 2.4.6 Still hitting ierror

[!] CocoaPods could not find compatible versions for pod “GoogleUtilities/Environment”:
In Podfile:
CordovaPluginsStatic (from ../capacitor-cordova-ios-plugins) was resolved to 2.4.6, which depends on
Firebase/Auth (~> 6.32.2) was resolved to 6.32.2, which depends on
Firebase/CoreOnly (= 6.32.2) was resolved to 6.32.2, which depends on
FirebaseCore (= 6.10.2) was resolved to 6.10.2, which depends on
GoogleUtilities/Environment (~> 6.7)

CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.6, which depends on
  GoogleUtilities (~> 7.2.2) was resolved to 7.2.2, which depends on
    GoogleUtilities/Environment (= 7.2.2)

My package file if it helps

{
  "name": "palmer",
  "version": "0.0.1",
  "private": true,
  "dependencies": {
    "@capacitor/android": "^2.4.0",
    "@capacitor/core": "2.4.6",
    "@capacitor/ios": "2.4.6",
    "@ionic-native/core": "^5.29.0",
    "@ionic-native/firebase-analytics": "^5.30.0",
    "@ionic-native/firebase-authentication": "^5.29.0",
    "@ionic-native/google-plus": "^5.29.0",
    "@ionic/react": "^5.4.0",
    "@ionic/react-router": "^5.4.0",
    "@testing-library/jest-dom": "^4.2.4",
    "@testing-library/react": "^9.4.0",
    "@testing-library/user-event": "^8.0.3",
    "@types/jest": "^24.0.25",
    "@types/node": "^12.12.24",
    "@types/react": "^16.9.17",
    "@types/react-dom": "^16.9.4",
    "@types/react-router": "^5.1.4",
    "@types/react-router-dom": "^5.1.3",
    "cordova-plugin-firebase-analytics": "^5.0.0",
    "cordova-plugin-firebase-authentication": "^3.6.0",
    "cordova-plugin-googleplus": "^8.5.1",
    "cordova-support-android-plugin": "^1.0.2",
    "crypto-js": "^4.0.0",
    "dummy-placeholder": "^1.0.5",
    "firebase": "^6.3.2",
    "graphql": "^15.3.0",
    "ionicons": "^5.0.0",
    "lodash": "^4.17.20",
    "node-fetch": "^2.6.1",
    "react": "^16.13.0",
    "react-dom": "^16.13.0",
    "react-fakeimg": "^1.0.11",
    "react-placeholder-img": "^1.0.0",
    "react-random-image": "^1.0.3",
    "react-router": "^5.2.0",
    "react-router-dom": "^5.2.0",
    "react-unsplash-wrapper": "^1.1.5",
    "typescript": "3.8.3"
  },
  "scripts": {
    "start": "react-scripts start",
    "dev": "env ENVIRONMENT_NAME=development react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test",
    "eject": "react-scripts eject",
    "android:build": "ionic cap build android",
    "android:watch": "ionic cap run android --livereload --external",
    "ios:watch": "ionic cap run ios --livereload --external"
  },
  "eslintConfig": {
    "extends": "react-app"
  },
  "browserslist": {
    "production": [
      ">0.2%",
      "not dead",
      "not op_mini all"
    ],
    "development": [
      "last 1 chrome version",
      "last 1 firefox version",
      "last 1 safari version"
    ]
  },
  "devDependencies": {
    "@capacitor/cli": "^2.4.6",
    "react-scripts": "3.4.4"
  },
  "description": "An Ionic project"
}

Did try updating your pods?

Yes Pod Update fires off the same error as well as Pod install.
Pod update throws the same error.

pod install --repo-update - Same error

Thank you will take a look at this

My pod file

platform :ios, '11.0'
use_frameworks!

# workaround to avoid Xcode caching of Pods that requires
# Product -> Clean Build Folder after new Cordova plugins installed
# Requires CocoaPods 1.6 or newer
install! 'cocoapods', :disable_input_output_paths => true

def capacitor_pods
  # Automatic Capacitor Pod dependencies, do not delete
  pod 'Capacitor', :path => '../../node_modules/@capacitor/ios'
  pod 'CapacitorCordova', :path => '../../node_modules/@capacitor/ios'
  pod 'CordovaPluginsStatic', :path => '../capacitor-cordova-ios-plugins'
  # Do not delete
end

target 'App' do
  capacitor_pods
 pod 'Firebase/Auth'
 pod 'Firebase/Analytics'
 pod 'Firebase/DynamicLinks'

end

✔ update android in 143.90ms
✔ Copying web assets from build to ios/App/public in 319.61ms
✔ Copying native bridge in 1.28ms
✔ Copying capacitor.config.json in 1.19ms
  Found 4 Cordova plugins for ios
    cordova-plugin-firebase-analytics (5.0.0)
    cordova-plugin-firebase-authentication (3.6.0)
    cordova-plugin-googleplus (8.5.2)
    cordova-plugin-inappbrowser (5.0.0)
✔ copy in 500.44ms
✔ Updating iOS plugins in 21.06ms
  Found 0 Capacitor plugins for ios:
  Found 4 Cordova plugins for ios
    cordova-plugin-firebase-analytics (5.0.0)
    cordova-plugin-firebase-authentication (3.6.0)
    cordova-plugin-googleplus (8.5.2)
    cordova-plugin-inappbrowser (5.0.0)
✖ Updating iOS native dependencies with "pod install" (may take several minutes):
✖ update ios:
[error] Analyzing dependencies
[!] CocoaPods could not find compatible versions for pod "Firebase/Analytics":
  In Podfile:
    CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.6, which depends on
      Firebase/Analytics (~> 7.0.0)

    Firebase/Analytics

CocoaPods could not find compatible versions for pod "Firebase/Auth":
  In Podfile:
    CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.6, which depends on
      Firebase/Auth (~> 6.32.2)

    Firebase/Auth

CocoaPods could not find compatible versions for pod "Firebase/CoreOnly":
  In Podfile:
    CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.6, which depends on
      Firebase/Analytics (~> 7.0.0) was resolved to 7.0.0, which depends on
        Firebase/Core (= 7.0.0) was resolved to 7.0.0, which depends on
          Firebase/CoreOnly (= 7.0.0)

    CordovaPluginsStatic (from `../capacitor-cordova-ios-plugins`) was resolved to 2.4.6, which depends on
      Firebase/Auth (~> 6.32.2) was resolved to 6.32.2, which depends on
        Firebase/CoreOnly (= 6.32.2)

Was able to solve by manually updating the
“cordova-plugin-firebase-analytics”: “^5.0.0”,
“cordova-plugin-firebase-authentication”: “^4.0.2”,

in the package-file got it to but crashes on open but one step closer cheers!

hey having the same issue. were you able to make any progress?