Changes in Html file not reflecting after build


#1

Transferred a project files to another computer but when I update the Html files, the changes i made in Html files are not reflecting after build, any idea what’s wrong here?

Ionic -v
2.0.0
Node -v
v6.9.1
Npm -v
3.10.9
Cordova -v
6.4.0


#2

Installed all the necessary node modules again? Seems like your build proces is broken.


#3

Hi @luukschoen, i think i installed it all using npm install, should i delete the node_modules folder and run the npm install again?


#4

Yes, I should definitely try that. Also make sure your Ionic CLI is up to date.


#5

@luukschoen i tried to run the npm install again but i got some errors and then i run it with --unsafe-perm=true

then i tried to run ionic platform add ios into my project but it returns an error saying

iOS project created with cordova-ios@4.3.1

Running command: /Users/shinji/desktop/project/myApp/hooks/after_prepare/010_add_platform_class.js /Users/shinji/desktop/project/myApp

Error: spawn EACCES


#6

Are you running it as system administrator? Otherwise (on mac) use the sudo prefix to make sure you run the command as a super user.


#7

@luukschoen im running it on mac, i tried to run sudo ionic platform add ios and i get the same error message

Creating Cordova project for the iOS platform:
path: platforms/ios
package: com.shinji.myApp
name: myApp

ios project created with cordova-ios@4.3.1
Running command: /Users/shinji/desktop/project/myApp/hooks/after_prepare/010_add_platform_class.js /Users/shinji/desktop/project/myApp

Error: spawn EACCES


#8

Can you try it with a brand new project? Make sure the platform is installed etc etc. Then move your files over? Pain in the ass…


#9

will try that, right now i opened it on xcode but getting an error “the file myApp.xcworkspace” could not be unblocked.

loosing my hair this is so much pain in the ass…


#10

It definitely sounds like a read/write issue


#11

what files should i copy from my current project files to the brand new project folder?


#12

If you started a brand new project with the latest RC(4) and build scripts (0.0.47 I think), you should copy over your src folder for the biggest part. So copy over your assets, theme, providers, pages, components (and what not) to the new src folder. then make sure you inject everything again in the correct maner inside your app.module file. Also make sure you only have 1 main file under your app folder, because since RC4 we don’t need the separate dev/prod file anymore.


#13

thanks will try that, is there something missing or wrong in my ionic installation?

here is what i have

Cordova CLI: 6.4.0
Ionic CLI Version: 2.1.17
Ionic App Lib Version 2.1.7
ios-deploy version: 1.9.0
ios-sim version: 5.0.13
OS: macOS Sierra
Node Version: v6.9.2
Xcode version: Xcode 8.2 Build 8C38

#14

In your package.json, what is the version listed for @ionic/app-scripts in devDependencies?


#15

@mhartingon here is what i have in my devDependencies

"@ionic/app-scripts": "0.0.39",
"typescript": "2.0.6"

#16

now i reinstalled the ionic and nodes, i am getting this error message after running ionic platform add ios, i already tried sudo ionic platform add ios

Error: EACCES: permission denied, open '/Users/shinji/desktop/myApp/platforms/platforms.json