Ionic app changes are not working

Hi Guys,
Please help me out.
I got already existed project with ionic framework 1.3.1 and Angular 2.So installed latest ionic CLI 3.19.1.
When I run ionic Cordova build iOS it says warning like “Not performing Ionic build for project type: ionic1.” but at the end, it showing build succeeded.

But my changes in an HTML page is not reflecting into the app.but when I changed something in CSS file it getting reflecting, but when adding an element it’s not getting reflecting into the app.

below is the result of ionic info command.

cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.19.1
ionic (Ionic CLI) : 3.19.1

global packages:

cordova (Cordova CLI) : 8.0.0

local packages:

Cordova Platforms : android 5.1.1 ios 4.2.1
Ionic Framework   : ionic1 1.3.1


Node  : v7.10.0
npm   : 4.2.0
OS    : macOS Sierra
Xcode : Xcode 9.2 Build version 9C40b

Environment Variables:

ANDROID_HOME : not set


backend : pro

My observations. there is a file called templateCache.js if I change anything then it’s reflecting into the app.I’m not sure why this file is?also, there is no app script and typescript written in package.json under devDependencies.

Please help me guys.

Thanks in advance.

Try “cordova clean ios” then “cordova build ios” in CLI

Thanks cedrickd, tried but not working.tried from CLI and run app from Xcode.

I solved this.i deleted templateCache.js now what ever i’m changing in html file its getting reflecting.
But When i run command ionic cordova build ios templateCache.js creating again. and reproducing the same problem even myu logs also logging from app.min.js only.