App build doesn't reflect changes


#1

Running into an odd issue, I am hoping someone has seen before. I have a simple app that I’ve started, and everything was working as expected until recently. Now when I make changes to an html page, it doesn’t show up when I use ionic server, or even ionic emulate ios. For example I will remove an entire section, but the list still shows up. I’ve gone as far as making completely empty. I’ve tried different browsers, stopping the server, and restarting it. Even restarting my laptop. When I look at the www/build/pages I see the changes in there, so I’m rather confused about why it isn’t changing when running.

Any ideas?


#2

Have you tried with ionic serve or ionic run with –livereload?


#3

Yes, and no luck. Nothing I’ve tried reflects the changes.


#4

So could you provide the out put from ionic info


#5

Sure:

doug$ ionic info

Your system information:

Cordova CLI: 6.0.0
Ionic Version: 2.0.0-beta.3
Ionic CLI Version: 2.0.0-beta.19
Ionic App Lib Version: 2.0.0-beta.9
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Mac OS X El Capitan
Node Version: v4.4.0
Xcode version: Xcode 7.2.1 Build version 7C1002


Dependency warning - for the CLI to run correctly,
it is highly suggested to install/upgrade the following:

Install ios-sim to deploy iOS applications. npm install -g ios-sim (may require sudo)
Install ios-deploy to deploy iOS applications to devices. npm install -g ios-deploy (may require sudo)



#6

Ugh! Stupid mistake on my part. I had renamed a page a while ago, but didn’t update:

@Page({
templateUrl: ‘build/pages/home/home.html’
})

And that page was still in the www/build/pages

Sorry for wasting everyones time :frowning: