Cant run ionic blank template on MAC OS X El Capitan

My attempts to run the Ionic2 blank template on osX El Capitan,
Deploying to iPhone-SE, 10.2 simulator or iPhone 7 Plus always result in
followed by the "white screen of death"
Seems the world is NOT my oyster.

Ionic info:

Cordova CLI: 6.5.0
Ionic CLI Version: 2.2.1
Ionic App Lib Version: 2.2.0
ios-deploy version: 1.9.1
ios-sim version: 5.0.13
OS: OS X El Capitan
Node Version: v6.10.0
Xcode version: Xcode 8.2.1 Build version 8C1002

ionic start Test blank --v2
cd Test
ionic platform add ios
ionic prepare ios
ionic emulate ios --consolelogs
—> “white screen of death” instead of “the world is your oyster”

I assume it works fine if you just run $ ionic serve?
Use Safari to remote debug the app in the emulator. Odds are the error will have already occurred and not written to the console log. Reload the app using the reload button the inspector. It should catch the issue and you can then hopefully resolve it.

Thanks very much Chris for your quick reply.
Yes, it does run fine if I just run $ ionic serve.

I tried the Safari inspector, but all I was able to see were running processes.

  1. I am using a borrowed Taiwanese MacBook Air ( I don’t know how that is relevant )
  2. I have never used a Mac before, and cant yet find a relevant account of how to use Safari inspector on this
    particular OS. The accounts refer e.g. to buttons that don’t exist or are greyed out.

I have tried launching from Terminal and from xCode. Same result- except that in one of the Terminal attempts the Simulator hung showing the splash-screen icon, whereas in all other cases the splash-screen icon faded to a white screen.

I have saved the logs, but how to show them here?
================ 29 MAR 17 Launch from xCode =====================

objc[9494]: Class PLBuildVersion is implemented in both /Applications/ (0x10f66c998) and /Applications/ (0x10f3eb880). One of the two will be used. Which one is undefined.
2017-03-29 18:08:25.235 Test[9494:875863] DiskCookieStorage changing policy from 2 to 0, cookie file: file:///Users/apple/Library/Developer/CoreSimulator/Devices/ADDC7E4A-2DD5-46B3-8942-A12AE99A3304/data/Containers/Data/Application/5F061E1A-39DD-49D1-8B6E-3A8D4AB24966/Library/Cookies/com.ionicframework.test315366.binarycookies
2017-03-29 18:08:25.300 Test[9494:875863] Apache Cordova native platform version 4.1.1 is starting.
2017-03-29 18:08:25.301 Test[9494:875863] Multi-tasking -> Device: YES, App: YES
[DEBUG] Did open IPv4 listening socket 9
[DEBUG] Did open IPv6 listening socket 10
[INFO] GCDWebServer started on port 8080 and reachable at
2017-03-29 18:08:25.368 Test[9494:875863] CDVWKWebViewEngine: trying to inject XHR polyfill
2017-03-29 18:08:25.378 Test[9494:875863] CDVWKWebViewEngine will reload WKWebView if required on resume
2017-03-29 18:08:25.378 Test[9494:875863] Using Ionic WKWebView
2017-03-29 18:08:25.379 Test[9494:875863] [CDVTimer][handleopenurl] 0.117958ms
2017-03-29 18:08:25.382 Test[9494:875863] [CDVTimer][intentandnavigationfilter] 3.032982ms
2017-03-29 18:08:25.383 Test[9494:875863] [CDVTimer][gesturehandler] 0.105023ms
2017-03-29 18:08:25.418 Test[9494:875863] [CDVTimer][splashscreen] 35.111964ms
2017-03-29 18:08:25.426 Test[9494:875863] [CDVTimer][statusbar] 7.857025ms
2017-03-29 18:08:25.428 Test[9494:875863] [CDVTimer][keyboard] 1.691997ms
2017-03-29 18:08:25.429 Test[9494:875863] [CDVTimer][TotalPluginStartup] 49.724996ms
2017-03-29 18:08:28.306 Test[9494:875863] Ionic Native: deviceready event fired after 1391 ms

The memory usage looked excessive to me ( But I dont know what would be normal)
Memory usage High: 37.7 MB,
—after a few minutes: Memory usage: 37.3 MB
CPU: 0
Disk: Zero
Network: Zero

The erratic display: (hung on splash-screen icon or faded to white) is the sort of erratic behaviour I would expect from a deadlock: Just a thought.

Hello, can anyone deploy an app to simulator or device on MAC OS X El Capitan ?

If so, I would be very grateful if you could just list “$ Ionic info” for me, and tell me what simulator or device works for you ( As above, when I try I get ** BUILD SUCCEEDED ** followed by a hung simulator ).

I need to decide what to do next.

I have overcome this problem by purchasing a used Mac Mini for this job. With this Mac, running OS x Sierra, I had no problems at all. The Blank app ran ok on an iPhone simulator. Even my app ran without errors.

It appears there was something unusual about my attempts to use a borrowed Mac for the purpose.

If you encounter the problem, take heart, there is at least this (drastic) way out.