AutoHideSplashScreen preference doesn't work even i couldn't remove splash screen


#1

Hi i followed the tutorial http://learn.ionicframework.com/formulas/splash-screen/

I could not get it working. Plus I tried to remove splash screen completely with ionic plugin rm “cordova-plugin-splashscreen”

Just splash screen is still there its being display 2-3 seconds all the time and goes away all my efforts doesnt work

What can i do ?

I Have followings in the config.xml

<preference name="webviewbounce" value="false"/>
<preference name="UIWebViewBounce" value="false"/>
<preference name="DisallowOverscroll" value="true"/>
<preference name="BackupWebStorage" value="none"/>
<preference name="SplashScreen" value="screen"/>
<!-- <preference name="SplashScreenDelay" value="3000"/> -->
<preference name="AutoHideSplashScreen" value="false" />
<preference name="auto-hide-splash-screen" value="false" />

#2

Hey foxitcl,
I am new with ionic but try to give a solution of your problem.
Install ng-cordova and put ng-cordova.min.js before cordova.js and after ionic.bundle.js.
Then add this code in app.js:

$ionicPlatform.ready(function() {
$cordovaSplashscreen.hide();
});


#3

Thanks for the help i’m already using ngCordova but i actually want it to show on screen forever


#4

There is another tricks to do that:
increase the value of SplashScreenDelay to value=“10000000000000” or greater and can check, just my thinking that may work.


#5

Thanks that did the trick. unfortunately if we go home and then return application the splash screen disappears :frowning:


#6

There is another tricks to remove splash screen:

  • Install cordova.splashscreen plugin in your app. Example:

$ cd myapp
$ cordova plugin add org.apache.cordova.splashscreen

  • change the defaults.xml in myapp/platforms/ios/cordova/

(preference name=“AutoHideSplashScreen” value=“false” />
preference name=“ShowSplashScreenSpinner” value=“false” />)

*add in your controllers.js:

angular.module(‘starter.controllers’, [])

.run(function($ionicPlatform) {
$ionicPlatform.ready(function() {
setTimeout(function() {
navigator.splashscreen.hide();
}, 100);
});
})

It will look like that no splash screen.


#7

The problem is cordova android 3.x.x bundled with SplashScreenInternal.java thats because i dont able to remove splash screen. Quick check in platforms\android\CordovaLib\src\org\apache\cordova folder search for SplashScreenInternal.java
When i run cordova platform update android it updates to 3.7.1

$ cordova platform update android
npm http GET https://registry.npmjs.org/cordova-android/3.7.1
npm http 200 https://registry.npmjs.org/cordova-android/3.7.1
npm http GET https://registry.npmjs.org/cordova-android/-/cordova-android-3.7.1.tgz
npm http 200 https://registry.npmjs.org/cordova-android/-/cordova-android-3.7.1.tgz
Updating android project…
Android project is now at version 3.7.1

And we have no effect with AutoHideSplashScreen so just beacues of these we dont able to completely remove splash screen


#8

I’ll updated cordova cli with npm update -g cordova to version 5.0.0 and i updated platform with cordova platform update android and finally i got cordova-android@4.0.0 platform which is not bundled with SplashScreenInternal.java

I hope it helps someone else


#9

Really?
WoW! That’s great. :smiley:
@foxitcl


#10

Hi foxitcl,

I have the same cordova version as yours were, i perform the cordova update and now I don’t have SplashScreenInternal.java file but still my splash screen remove itself even if i have AutoHide property false :s


#11

Hi,

As i understand you manually installed cordova splash screen plugin to have splash screen. I didn’t experience it with AutoHide property but you can try setting SplashScreenDelay to really high value like @motiurion mentioned then you can close it in your app’s js