Android SplashScreen Autohide FALSE not working


#1

AutoHideSplashScreen=“false” works on iOS and we then hide when ready. But whatever we do we can’t get android to keep the splash screen showing until we tell it to go.

Any ideas? Is this a problem with the android variant of the splash screen plugin?


#2

Struggling with this on android.
Stupid workaround -
Increase the default splashscreen timeout in config.xml to an insane number say 120 secs (A number before which you will finish your background tasks and would want to hide the splash screen)
Now in ready function call when you done with your tasks.
$cordovaSplashscreen.hide();


#3

Already tried setting it to 15 seconds - but will try going to a crazy extreme.


#4

Having the same problem

so … is there a fix? Or do I need to bump up the delay?

some info

Cordova CLI: 5.4.1
Gulp version:  CLI version 3.9.0
Gulp local:   Local version 3.9.0
Ionic CLI Version: 1.7.12
Ionic App Lib Version: 0.6.5
ios-deploy version: 1.8.3 
ios-sim version: 5.0.4 
OS: Mac OS X El Capitan
Node Version: v4.2.2
Xcode version: Xcode 7.2 Build version 7C68 

and using the cordova-plugin-splashscreen plugin


#5

Same issue here,

I tried with a 60s delay,

    <preference name="SplashScreen" value="screen" />
    <preference name="splashScreenDelay" value="60000" />
    <preference name="SplashMaintainAspectRatio" value="false" />
    <preference name="AutoHideSplashScreen" value="false" />


// with in the code a navigator.splashscreen.hide();

I can see my image, but only for an instant and then it desapears…


#6

I ended up with something like

  <preference name="SplashScreen" value="screen"/>
  <preference name="ShowSplashScreenSpinner" value="true"/>
  <preference name="AutoHideSplashScreen" value="false"/>
  <preference name="SplashScreenDelay" value="150000"/>
  <preference name="android-targetSdkVersion" value="20"/>
  <feature name="SplashScreen">
    <param name="android-package" value="org.apache.cordova.splashscreen.SplashScreen"/>
    <param name="onload" value="true"/>
  </feature>

and I close the splashscreen

$cordovaSplashscreen.hide();


#7

I was facing the same issue and this worked like a charm…