App working on my side but stuck on splash screen in App Review


#1

Hello,

I am submitting an Ionic iOS app for my enterprise but App Review send me this message after their test :

We discovered one or more bugs in your app when reviewed on iPhone and iPad running iOS 11.1.2 on Wi-Fi connected to an IPv6 network.

Specifically, the activity indicator spins indefinitely on launch. Please see the attached screenshot for details.

Next Steps

To resolve this issue, please run your app on a device to identify any issues, then revise and resubmit your app for review.

If we misunderstood the intended behavior of your app, please reply to this message in Resolution Center to provide information on how these features were intended to work.

I can’t reproduce their problem in any way, everything is working for me. It is an update of an application which was in Ionic 1 so we redevelopped it in Ionic 3. It is basically the same as another one which was successfully published 2 weeks ago. I asked them to tell me which iPad or iPhone they used and to retry a test but they responded with the same message not giving me any new information.

What could I try to do now ? Uploading the app again without any change is the only idea I’ve got so far and it isn’t the best one.


#2

Are you doing anything special in the startup of the app that could depend on network in a strange way?


#3

Nothing really special no, the use of network start at the login page and before that there is an index page which doesn’t communicate with our server yet. And as I said, the other app that is pretty much the same as this one was successfully published on the store so I don’t understand how this one can’t be accepted but the other one can.


#4

Then I would probably try to edit some random thing that doesn’t really matter and resubmit it with a new version and build number (just to make sure the reviewer doesn’t think you resubmitted the exact same thing… don’t want to piss them off, right?)


#5

That is what I tried this afternoon, I had to change some informations I forgot about. I’ll update this thread after the app has been reviewed. If it works, I guess there was some trouble during the upload or any weird other thing. Thank you !


#6

Finally, it was published yesterday. And… yep I was right : I did not change anything really (except for a text) and it passed the review without any trouble. Thought someone would like to read this in case they have the same problem.


#7

Awesome. Shows that sometimes things just go wrong.