App hangs at splash screen on ipad


#1

Possibly not related to ionic, but after a couple of installs through “ionic run ios” on my ipad, my app suddenly started hanging at the splash screen. I’ve ran the iphone configuration utility but nothing useful was showing up there in the console.

The app works in the browser and doesn’t trigger any errors in the console. I have no idea where to look now, any idea what can be the cause?


#2

Are you going to an actual device or an emulator? Also, is the app already running? AFAIK, ionic run ios is built on top of cordova run ios, which needs ios-sim. Ios-sim has never really worked too well, and has always been problematic.


#3

I unplugged my ipad and reconnected, reinstalled the app and it works again. I guess unplugging did the trick, not ionic related!


#4

Alright, glad to hear its resolved.

You should post the issue though to cordova

https://issues.apache.org/jira/browse/CB


#5

Im having the same problem. I can run the app fine when simulator or on a connected device. Then I generated an ipa for doing a closed group test and installing the ipa gives me a blank screen (initially I just saw the Cordova splash screen but subsequent installs/runs now just give me a blank screen).


#6

Hmm, are you making any http requests? Overall, it sounds like there are some errors in your ipa somewhere.


#7

I found the bug and fixed it (incorrect fallback routing) so all is well.


#8

I’ve had a couple of similar experiences. I usually build and test my apps on iOS using XCode, and rely on the console there for error messages, but I was occasionally getting to the stage where my app would not start properly, but I wouldn’t see anything in XCode.

I found that if I turned on Web Inspector on my device, and then used Safari to debug my running app, the Safari developer console would give me a lot more debug information than XCode, and this has helped me to debug things like variables being null when a value was expected etc.

I normally dislike using the Safari developer tools as you cannot actually start the tool until the app is ALREADY running on the device, thus reducing the effectiveness of debugging startup code, but I learned a great tip on this forum, which is to enter the command

window.location.reload()

in the Safari developer console to restart your app so you can do start up debugging… Hope this helps.


#9

I’m also having this same problem on my iPhone running 8.1. I click run, it seems to do the trick, opens the app on the iPhone but then it just hangs on the splash screen.

I did have some plugin warnings so I removed the plugins but it still just freezes.

@mhartington I do have HTTP requests, what impact does that have?


#10

So a few questions, Are you calling navigator.splashscreen.hide(); on device ready?
Have you disabled the auto hiding of the splash screen?

Can you provide anymore info?


#11

Hey @mhartington - I actually realised when looking at Xcode that I’m actually getting a strange error thats stopping the app from opening: Xcode error

Way out of my depth!

Thanks,
Geoff


#12

Do you have any plugins installed?
Any chance you could put together a codepen I could look at?


#13

Only org.apache.cordova.splashscreen on top of the default.

Not really sure how to set up a codepen for the entire app - I did just add you as a collaborator on the GitHub repo though…


#14

Cool, just got the email.
Will look at the project


#15

Awesome.

I did create a new blank app just to be sure it wasn’t something environment based. That worked fine.


#16

Alright, can I commit to the repo? I can see if there are any issues and push it up


#17

Interesting, I wasn’t able to reproduce the issue on my iphone6 running ios 8


#18

@mhartington - you mean it actually ran fine for you? No error?

I’ll try cloning the repo again, I can’t think what it might be but maybe it will make a difference,


#19

@mhartington got it working. Removing and readding iOS seemed to do the trick! Thanks for your help.


#20

Good to hear. Glad you got it figured out.