After uploading a new Android update, me and other users, can install the app but cannot start the app in way and is not shown on the Home Screen

Like the title says, after anew update, the clients or me can see the app in the app list or the home screen or even start the app in some other way. The app can be installed (from the Play Store) and uninstalled, but that’s about it.

When debugging, I can install the app on the device as I normally do (using Android Studio) and it works as expected. This only happens when downloading from the Play Store.

💊   Capacitor Doctor  💊 

Latest Dependencies:

  @capacitor/cli: 4.6.2
  @capacitor/core: 4.6.2
  @capacitor/android: 4.6.2
  @capacitor/ios: 4.6.2

Installed Dependencies:

  @capacitor/cli: 4.6.1
  @capacitor/android: 4.6.1
  @capacitor/core: 4.6.1
  @capacitor/ios: 4.6.1

[success] iOS looking great! 👌
[success] Android looking great! 👌

I don’t know what else to add, so if you need more details, please be specific.

If anybody wants to test if it shows or starts in their device:

Maybe the problem could be that the device is not on the device list? But if that is so, this could be an issue with capacitor 4?
This is not the problem, my device should be working correctly because is on the list.

Bizarre! Just installed it on my Pixel 7 and it installs but as you are encountering, doesn’t give the option to Open in the Play Store and doesn’t show in the App List to open.

What does your /android/variables.gradle look like?

ext {
    minSdkVersion = 22
    compileSdkVersion = 32
    targetSdkVersion = 32
    androidxActivityVersion = '1.4.0'
    androidxAppCompatVersion = '1.4.2'
    androidxCoordinatorLayoutVersion = '1.2.0'
    androidxCoreVersion = '1.8.0'
    androidxFragmentVersion = '1.4.1'
    coreSplashScreenVersion = '1.0.0-rc01'
    androidxWebkitVersion = '1.4.0'
    junitVersion = '4.13.2'
    androidxJunitVersion = '1.1.3'
    androidxEspressoCoreVersion = '3.4.0'
    cordovaAndroidVersion = '10.1.1'

Looks the same as mine!

Maybe for kicks, try creating a new build and submitting to the Play Store?

I already tried that before posting here with no luck but it did gave me the idea to just delete the folder.

After deleting the android folder generated by capacitor and adding it again (using the cap add android), I ran the new generated build on my device. Then I could see the icon on the home screen and app list again.

I decided to use this version for the build that I will upload to the Play Store. If everything work correctly, I will mark this post as the solution, but thanks a lot @twestrick.

But this situation did teach me to never deploy on production lmao.