XCode tells me to install cordova-plugin-local-notification, even though it's installed


#1

Hi everyone :slight_smile:
I’m trying to use local notifications for ionic.

I want to ask the user for permission to use local notifications.
But when I call registerPermission() I get the following error:

WARN: Native: tried calling LocalNotifications.registerPermission, but the LocalNotifications plugin is not installed.
WARN: Install the LocalNotifications plugin: 'ionic cordova plugin add cordova-plugin-local-notification

The strange thing is: It is installed! I only got the idea to ask for permission first, because I didn’t want my already working scheduled notification to ask for permission…

Also here is the entry in the config.xml file:

<plugin name="cordova-plugin-local-notification" spec="^0.9.0-beta.2" />

What could be the reason for this issue?


#2

I’m having the same error with android. Plugin is installed but warns me to install it and it does not work.


#3

OK. I’ve found a solution. You’ll need to uninstall the plugin:
ionic cordova plugin rm cordova-plugin-local-notification
npm uninstall --save @ionic-native/local-notifications

After that, install it again using:
ionic cordova plugin add de.appplant.cordova.plugin.local-notification
npm install --save @ionic-native/local-notifications

This will install version 0.8.5 not 0.9.0-beta.2 like before.


#4

Thank you very much for this answer!