Xcode couldn't find any provisioning profiles matching


#1

I am trying to rebuild an app, that previously had no issues (first rebuild in 6 months or so). Environment is OSX with all the latest updates, Ionic is 3.20.0.

These plugins:

cordova-plugin-device
cordova-plugin-file
cordova-plugin-file-transfer
cordova-plugin-splashscreen
cordova-plugin-whitelist
cordova-plugin-x-socialsharing

I cannot make this error go away:

Check dependencies
Code Signing Error: No profile for team ‘8SEBNER3XM’ matching ‘ABM 2018 Dev’ found: Xcode couldn’t find any provisioning profiles matching ‘8SEBNER3XM/ABM 2018 Dev’. Install the profile (by dragging and dropping it onto Xcode’s dock item) or select a different one in the General tab of the target editor.
Code Signing Error: Code signing is required for product type ‘Application’ in SDK ‘iOS 11.4’

** ARCHIVE FAILED **

The following build commands failed:
Check dependencies
(1 failure)
Error: Error code 65 for command: xcodebuild with args: -xcconfig,/Users/kerickhowlett/Documents/PhoneProjects/ABM/platforms/ios/cordova/build-debug.xcconfig,-workspace,Cocktail Pro.xcworkspace,-scheme,Cocktail Pro,-configuration,Debug,-destination,generic/platform=iOS,-archivePath,Cocktail Pro.xcarchive,archive,CONFIGURATION_BUILD_DIR=/Users/kerickhowlett/Documents/PhoneProjects/ABM/platforms/ios/build/device,SHARED_PRECOMPS_DIR=/Users/kerickhowlett/Documents/PhoneProjects/ABM/platforms/ios/build/sharedpch

Despite what the message says, there is what seems to be perfectly valid provisioning profiles in both Xcode project General tab, and Build Settings. At least, Xcode thinks they are valid from within Xcode. Running as ‘ionic cordova build ios’ seems to have a different opinion. Base on trial an error, it is the PROVISIONING_PROFILE_SPECIFIER that seems to be the issue.

What am I missing??? Thanks.


#2

I have the same problem, how did you solve it?


#3

I never could find the exact cause. I think it was related to one of the certificates. So I recreated certificates, and went through all the configuration from scratch. I tried many, many things so not sure what really fixed it.


#4

hi, did u figured out the solution yet? i have the same problem, tried removing and adding platfom but that doesnt work.


#5

uncheck
auto signing
then check it again in Xcode build settings


#6

Hi, it’s not working but thanks for helping.
As of now i still can’t run directly from cmd.
I build using cmd first for changes to take effect(the signing error is still there), then hit the play button in xcode(since no signing error in xcode) to run and install.