Www folder inside platform folder is not updated

After I saved my files and run
ionic build ios

the emulator still on the old code and not updated. I have to copy the www folder manually to /platform/ios

This is my system info:
Cordova CLI: 5.3.1 Ionic Framework Version: 3.0.1 Ionic CLI Version: 2.2.2 Ionic App Lib Version: 2.2.1 Ionic App Scripts Version: 1.3.2 ios-deploy version: 1.9.1 ios-sim version: 5.0.13 OS: macOS Sierra Node Version: v6.2.1 Xcode version: Xcode 8.1 Build version 8B62

Try running ionic serve before building.

No, this not working too.

Terrible solution, but: Try removing and re-adding the ios platform.

No this not working too. I manually copied the files because at first time I build my app this screen was shown to me. So, I thought that my project was empty and manually copying was my check

Is this possibly a permission problem where you ran something as root and now an ordinary user doesn’t have write access to the build directory?

1 Like

I don’t have idea. But I tried build with sudo too.

Did you ever find a fix for this? I’m experiencing the same issue. I have to manually copy files from www into /build to update my compiled app. Somhow, even if I delete files from project/www, project/src and build/android, when I run ionic cordova emulate android, it restores these old files. I don’t even know where it is storing them.

I have the same issues. Was this every resolved?

I hope that my answer will help someone else. Delete the www folder in your project and run

ionic build

This will update your folder.

4 Likes

Thanks it works perfect!.

1 Like