Would "@angular/router": "3.0.0-beta.1" work with beta.10


#1

Beta.10 comes with

"@angular/router": "^2.0.0-rc.2"

However doc seems to be based on 3.0.0

If I force update @angular/router to 3.0.0, would beta.10 still work? In that case when could I expect ionic 2 to incorporate the latest version?

Thanks.


New Angular2 Router support in Ionic
#2

Ionic 2 still doesn’t use Angular’s 2 Router on its Navigation, it’s on implementation so it doesn’t matter yet.


#3

Someone posted a similar question here, and I made reply to it. So far I haven’t managed to make routing work unfortunately.