White screen after ionic cordova update for bug fix

I developed an old ionic angular cordova app.

I had to make new changes to solve a business problem. I can build the app. I can run it in the simulator. the splash screen appears. a blank page always appears and I can’t do anything

In the XCode log I have several errors/warnings:

FBSDKLog: Starting with v13 of the SDK, a client token must be embedded in your client code before making Graph API calls. Visit https://developers.facebook.com/docs/ios/getting-started#step-3---configure-your-project to learn how to implement this change.

Failed to request allowed query parameters from WebPrivacy.

*** -[NSKeyedUnarchiver validateAllowedClass:forKey:] allowed unarchiving safe plist type ''NSString' (0x7ff841f18bb8) [/Library/Developer/CoreSimulator/Volumes/iOS_21E213/Library/Developer/CoreSimulator/Profiles/Runtimes/iOS 17.4.simruntime/Contents/Resources/RuntimeRoot/System/Library/Frameworks/Foundation.framework]' for key 'NS.keys', even though it was not explicitly included in the client allowed classes set: '<decode: bad range for [%{public}@] got [offs:686 len:489 within:0]>'. This will be disallowed in the future.<decode: bad range for [%{public}@] got [offs:1175 len:1 within:0]>

FBSDKLog: fb-messenger-share-api is missing from your Info.plist under LSApplicationQueriesSchemes and is required.

This is my configuration

Ionic:

   Ionic CLI                     : 6.18.1 (/usr/local/lib/node_modules/@ionic/cli)
   Ionic Framework               : @ionic/angular 6.7.4
   @angular-devkit/build-angular : 13.3.11
   @angular-devkit/schematics    : 12.2.18
   @angular/cli                  : 13.3.11
   @ionic/angular-toolkit        : 4.0.0

Cordova:

   Cordova CLI       : 11.0.0
   Cordova Platforms : ios 6.3.0, ios_ 6.3.0
   Cordova Plugins   : cordova-plugin-ionic-keyboard 2.2.0, cordova-plugin-ionic-webview 5.0.0, (and 17 other plugins)

Utility:

   cordova-res (update available: 0.15.4) : 0.15.3
   native-run                             : not installed globally

System:

   ios-deploy : 1.11.4
   ios-sim    : 8.0.2
   NodeJS     : v16.10.0 (/Users/lsantaniello/.nvm/versions/node/v16.10.0/bin/node)
   npm        : 7.24.0
   OS         : macOS
   Xcode      : Xcode 15.3 Build version 15E204a

I tried removing the ios platform and recreating it but it doesn’t solve the problem

Does anyone have any advice for me?

I would fix the FBSDKLog issues first and go from there. They tell you what is needed.

1 Like

Thanks for reply @twestrick. do you know how I can solve it?

I’m using this facebook plugin: “cordova-plugin-facebook-connect”: “^3.2.0”

"cordova-plugin-facebook-connect": {
        "APP_ID": "xxxxxx",
        "APP_NAME": "xxxxxx",
        "FACEBOOK_URL_SCHEME_SUFFIX": " ",
        "OTHER_APP_SCHEMES": " ",
        "FACEBOOK_AUTO_LOG_APP_EVENTS": "true",
        "FACEBOOK_HYBRID_APP_EVENTS": "false",
        "FACEBOOK_ADVERTISER_ID_COLLECTION": "true",
        "FACEBOOK_ANDROID_SDK_VERSION": "11.3.0",
        "FACEBOOK_IOS_SDK_VERSION": "11.1.0",
        "FACEBOOK_BROWSER_SDK_VERSION": "v11.0"
      }

In the my.plist file I added required keys:

Under CFBundleURLSchemesin the `, replace {your-app-id} with your App ID.

Under <key><FacebookAppID> </key> <string>, replace {your-app-id} with your App ID.`

From Developer Tool… :frowning:

codova file NOT FOUND

I found the problem. depends on the dynamic loading of the home page. an asynchronous condition is checked in the appcomponent that determines the home page the user should land on.

very strange. it always worked. I don’t know if it depends on the latest version of xcode I had to install

What is the best way to set the home page dynamically?