Warning Android API level 26


#1

I’ve published an update of my app in Google Play and got the warning that it is targeted to Android API level 25 and from next month it is necessary targeting Android API level 26. What have I to do? Have I to update cordova-android from 6.2.3 to >7.0.0?


#2

Hello,
check in config.xml preference for targetSdkVersion
Typically you have only set minsdkversion like

 <preference name="android-minSdkVersion" value="19" />

if no targetsdkversion is set, you do not need to change.

See more here https://pointdeveloper.com/build-ionic-2-cordova-apps-specific-platform-version/

Go in Android Studio to sdk-manager and check which sdk with witch api level is installed. Api level 26 is Oreo. Install it, if it isn’t installed. Remove lower levels. If you get problems with older apps, then you can add it later again, if nescesarry.

Best regards, anna-liebt


#3

Hello,

I just tried what you are suggesting, but I had no luck. I changed <preference name="android-minSdkVersion" value="19"> in my config.xml but I found that the warning on the Google Play’s review summary again.


#4

Ando con el mismo problema, acabo de cambiar en el config.xml:

<preference name=“android-minSdkVersion” value=“19” />

Y todavía no hago el BUILD para subir a producción. En cuanto lo suba a la PlayStore de Google te aviso si tuve algún problema. Espero que ya no me salga el aviso como a ti.


#5

You need to set the android-targetSdkVersion, not the min version. I had same issue and updating target version to 26 fixed it (just left the minSdkVersion as what it was)

These are the settings in my config.xml file…

<preference name=“android-minSdkVersion” value=“16” />
<preference name=“android-targetSdkVersion” value=“26” />