Visual Studio Error: VSTemplateWizard


#1

Hi everyone,

I downloaded Visual Studio Community and the Ionic Project Templates for it. As soon as I try to create an Ionic project I get this Error:

“Error: this template attempted to load component assembly ‘Microsoft.VisualStudio.MultiDeviceHybridApps.VSTemplateWizard, Culture=neutral’. For more information on this problem and how to enable this template, please see documentation on Customizing Project Templates.”

Am I missing something?
Thanks


#2

Hey there!

I don’t know if you’ve solved this already or not, but just in case… I was having this problem yesterday and found out that downloading the Visual Studio Community installer again, choosing “Repair” (I think, not sure) and adding the Tools for Mobile Development (or something like that, cant really remember the exact names - it includes Android emulator, some tools, etc - total of around 16GB for me) to the currently existing instalation fixed the error. It turns out my VS didnt have the proper tools to run the Ionic package (or any mobile package other than native WP, for that matter).

Hope it helps!


#3

I have been fighting with this issue for the past couple of days and here is what worked for me…

First a bit of background: I had been doing some development with Ionic in Visual Studio 2013 and recently installed Visual Studio 2015 Community. That’s when the problems started and I could no longer use the Ionic project templates.

I tried, many different things, but these are the steps that finally got it working:
-Uninstalled “Visual Studio Tools for Apache Cordova” from Add/Remove programs
-Uninstalled all versions of Node.js (I had two installed, 5.0 and 4.4.1)
-For good measure, after uninstalling node.js, I deleted the node.js folder under “C:\Program Files (x86)”
-I also deleted “C:\Users<user>\AppData\Roaming\npm” & “C:\Users<user>\AppData\Roaming\npm-cache”
-Then I re-ran the Visual Studio Community web installer and chose “Repair”.

When that finished, I was able to create a new project from the Blank Ionic App template.


#4

There is suggestion which I found on microsoft site here: https://visualstudiogallery.msdn.microsoft.com/4e44ba8b-a4c8-4106-b70e-00d63241a54a

One reason why you might be getting this error is because the templates have an inbuilt dependency on Tools for Apache Cordova. Please install the tools by clicking on File -> New Project -> JavaScript => ‘Install Tools for Apache Cordova’. If the error still exists, then please let me know.

I will try the above and report it here.