[Updated] CLI 3 Beta 4 ionic upload doesn't show up in Ionic View


#1

I just updated the ionic CLI today to version 3.0.0-beta.4, which so far is building faster and is also more responsive - so there are some definite good points - good job so far! :slight_smile:

It seems as though the functionality of ionic upload is different. The command seems to finish properly stating [OK] Uploaded snapshot guid. An actual guid does display - I just didn’t want to type it in here.

After this, nothing seems to change in Ionic View. I even deleted my app from Ionic View and pulled to swipe to update my app list but my app never returns.

Any help would be appreciated - I’m in the stages of testing on multiple devices with Ionic View so this is sort of holding me back.


Ionic 2.3.0 w/Angular 4.0.0
#2

I just tried to do another ionic update and am getting the following error:

$ ionic upload
✖ Requesting snapshot - failed!
API Error 401: POST https://api.ionic.io/deploy/snapshots
{ type: 'Unauthorized',
  link: null,
  message: 'Authentication failed' }

I re-did an ionic login which logs me in properly and am still getting the error.

Any ideas?


#3

Just an FYI… I have an open issue about this in the GitHub repository. It’s open and has been assigned.


#4

Any news on this?

I got same problem except that I dont get any error message when I upload. Its not showing up anything in Ionic View just.


#5

It was kinda-sorta fixed in beta.10 but it’s still having issues in rc.0. They know about the issues with ionic upload and it’s actively being worked on right now. The github issue in this forum thread is closed - it’s actively being tracked here.


#6

I was about the write a post :slight_smile:

Well I have just upgraded ionic to 3.1.1 with this guide:
https://forum.ionicframework.com/t/guide-how-to-update-to-ionic-3-x/87516/2?source_topic_id=84173

That solved the issue for me


#7

Yep, good stuff. I’m guessing you’re using CLI version 2.2.3 and that’s why it’s working for you. I’m using the ionic CLI version 3.0.0-rc.0 which is a release candidate and still sort of beta. It still has some kinks but is coming along. You can run the ionic info command to see all the version numbers of the ionic components you’re using.

If I were you, I’d stick with CLI 2.2.3 to keep things running properly for now.


#8

Nope, I have upgraded CLI as well to 3.0.0-rc.0

@ionic/cli-utils : 1.0.0-rc.0
Ionic CLI        : 3.0.0-rc.0
 Node       : v7.7.4
    OS         : macOS Sierra
    Xcode      : Xcode 8.3.2 Build version 8E2002 
    ios-deploy : not installed
    ios-sim    : not installed

Looks like this :slight_smile: