Ionic Upload Error - Ionic 2

Hello, I have been trying to upload my Ionic 2 app So that I can view it in Ionic View app on my phone.

The first few times it said it uploaded but wasn’t in the app when I opened it. Realizing I had two accounts (accidentally) I tried to sign in again. Since then I have been geting this error. [ERROR] A token does not exist for your account on App ‘2ebbcd89’.

Can anyone help? Tell me what to do or show me where to look? I’ve tried to search with no luck.



When you do in cli, ionic upload, make sure you are in your project folder. Then it will ask for password and stuff but main idea is, you must make sure you are inside your relevant folder. Same for ionic build and run.

Thank you so much for posting! I am in the project folder :(. Any other suggestions? Thanks!

Try ionic link again - something is borked with the app<-> connection.

1 Like

Thanks! That got it uploading again! Now when I try to search it in Ionic view it says “No Connection. Unable Download App” when searched and the app does not show up in ionic view on its own.

Any more suggestions?


Log into the ionic account online. Remove the app and create a new one. Get the name and I’d and paste those in one of the config files. Sorry I am not behind my PC so not sure which file it is.

I’ve had this before and this works.

Here is what I meant:

Just to make sure it is not caused by your CLI: Post the output of your ionic info please. Thanks.

Thank you all so much for replying! I did the ionic link and it says it is uploaded.
:heavy_check_mark: Requesting snapshot - done!
⠼ Uploading snapshot [===============] 100% 0.0s
:heavy_check_mark: Uploading snapshot - done!
[OK] Uploaded snapshot 5a5b5194-314a-4f0e-98f4-79121ec54a11!”

But it is not there when I look in my ionic view App.

Ionic info output is:
Your system information:

Cordova CLI: 6.5.0 
Ionic Framework Version: 2.3.0
Ionic CLI Version: 3.0.0-beta.5
ios-deploy version: Not installed
ios-sim version: 5.0.13 
OS: OS X El Capitan
Node Version: v6.9.2
Xcode version: Xcode 8.2 Build version 8C38


This is still an Ionic CLI v3 bug.
If you really want to use the Cloud Services you should run CLI V2.

1 Like