Does anyone have ionic upload working in CLI 3 beta?


#1

I’ve mentioned this before with no responses except in the GitHub issue I opened a while back. Ever since going to CLI 3.0.0-beta.4 / beta.5, I haven’t been able to get ionic upload working at all.

Whenever I try it, it tells me that the snapshot was uploaded successfully and then shows me a guid as a reference, such as ded0b4cf-470d-4e06-a3a8-9e2c83c8488d but nothing gets updated in Ionic View. In previous version(s) of the CLI (prior to v3), ionic upload worked but showed the app id, such as 60e2f424.

Is ionic upload working for anyone??


#2

Does the upload appear on the “Deploy” tab of your app on apps.ionic.io?


#3

In my Dev channel for my app on apps.ionoic.io I have the following two entries for the latest ionic upload:

Brad Note: deploy
56e4da0c · 5:14 PM on 2017-04-12

Brad Note: upload
56e4da0c · 5:14 PM on 2017-04-12
ACTIVE

This was achieved from the following:

$ ionic upload --note “Brad Note” --deploy dev
:heavy_check_mark: Retrieving deploy channel - done!
:heavy_check_mark: Requesting snapshot - done!
⠋ Uploading snapshot [===============] 100% 0.0s
:heavy_check_mark: Uploading snapshot - done!
[OK] Uploaded snapshot 56e4da0c-8f38-4f56-bb6c-6fcbfca940d0!
:heavy_check_mark: Uploading snapshot - done!
:heavy_check_mark: Deploying to ‘dev’ channel - done!
[OK] Deployed snapshot 56e4da0c-8f38-4f56-bb6c-6fcbfca940d0 to channel dev!

From here, still no change in Ionic View.

I’m also wondering why it’s saying it took 0.0s for the upload.


#4

Try leaving the options, just ‘ionic upload’. Am not sure if deployment has effect on Ionic View.


#5

I’ve done that many times and there’s no difference. In Ionic View on the device, my app is listed. When I tap on Download Files it says “FileTransfer Error”. There’s nothing wrong with the network or communication on the device so that’s not the problem.

I’m going to try and delete the app from the device and re-register with ionic link.


#6

So I deleted the app from Ionic View and it was automatically removed from apps.ionic.io.

Then I performed the following ionic link command and got the following:
$ ionic link
? Which app would you like to link Create a new app
[OK] Rerun ionic link to link to the new app.
events.js:163
throw er; // Unhandled ‘error’ event
^

Error: spawn /usr/lib/node_modules/ionic/dist/xdg-open ENOENT
    at exports._errnoException (util.js:1033:11)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:193:32)
    at onErrorNT (internal/child_process.js:367:16)
    at _combinedTickCallback (internal/process/next_tick.js:80:11)
    at process._tickCallback (internal/process/next_tick.js:104:9)

So that did nothing. I had to create the app in apps.ionic.io to get an app id and then did the following:
$ ionic link 1bc8b74f
[OK] Project linked with app 1bc8b74f!

Then did the following:
$ ionic upload --note "First Upload"
:heavy_check_mark: Requesting snapshot - done!
⠙ Uploading snapshot [===============] 100% 0.0s
:heavy_check_mark: Uploading snapshot - done!
[OK] Uploaded snapshot bdf3efe2-d03e-475f-9eef-6099b8b2cf6a!

In apps.ionic.io, it does show that the upload was performed with the following:

channel: Production
First Upload
Snapshot created: 5:46 PM on 2017-04-12 · bdf3efe2-d03e-475f-9eef-6099b8b2cf6a

First Upload: deploy
bdf3efe2 · 5:47 PM on 2017-04-12

First Upload: upload
bdf3efe2 · 5:46 PM on 2017-04-12

And in Ionic View… the app shows up. When I try to Download Files I still get the FileTransfer Error


#7

So now, I completely uninstalled Ionic View, cleared the data and reinstalled from the Google App Store.

One of my older apps does show up in Ionic View but not the current one which I’ve been pushing up with ionic upload.

So I tried to preview the app by entering the app id and Ionic View states: App Has No Files (Needs Upload)

When I tab the back button to the “My Apps” main page, it shows my app listed for about 1 second and then it disappears.

So ya, I’m out of options. Anyone??


#8

Okay, really weird issue. Have the exact same problem after updating the CLI to v3beta. It says it uploaded the app and created a snapshot, the snapshot shows up under my deploy channel within my apps -> specific app, but it is nowhere to be found within Ionic View. When I explicitly want to preview the app using the app id it says no files were uploaded.


#9

Ok so I’m not the only one. As I stated earlier in the thread, I’m also wondering why it’s saying it took 0.0s for the upload. Are you getting the same message?

Actually, with the newest CLI 3.0.0-beta.7 that timing number has been removed such as this:

$ ionic upload
✔ Requesting snapshot upload - done!
✔ Uploading snapshot - done!
[OK] Uploaded snapshot 6093d690-8cfc-4739-97e2-d24876c65a50!

So ya… again… I think I’ve gone through pretty much everything on this and still nothing gets uploaded (seemingly).


#10

I just downgraded my Ionic CLI version back to 2.2.2 and everything worked instantly. Seems like a bug in CLI 3.0.0-beta.7 that should be fixed. Let me see if I can file an issue / find and issue for that on the repo!


#11

Ok that sounds perfect. I was going to file an issue but I wanted to know if anyone else at all was experiencing the same issue. You can include a link to this thread in the Ionic-CLI github issue for reference.

Can you post a link to the github issue here when it’s done? I’ll like to keep track of it as well.

And thanks very much for verifying that I’m not going completely insane lol.


#12

Check this out: https://github.com/driftyco/ionic-cli/commit/5007e840c69d7ae92bd402c3ca4a667ed665f8da

v3 beta7 testing

Please ensure that you have updated your dependent packages. We have changed a few of the package names. https://github.com/driftyco/ionic-cli/tree/v3#existing-ionic2-project


#13

Yeah saw that as well while opening an issue. But my dependencies seem to be correct…


#14

Yep, thanks for that. Already did that and my dependencies are correct.


#15

Haha yeah I know that feeling, where you think it’s something you’re doing wrong. Well, maybe we are but it definitely seems to be a bug haha


#16

For some reason I was also wondering if it’s an operating system issue. I’m using the latest stable Linux MiNT 18.1. How about you?


#17

Hmm don’t think so, I;m running on macOS Sierra. The filed issue on github can be found over here:

For now I just rolled back to V2.2.2 and everything seems to work fine again. Without changing my dev dependencies, just the Ionic CLI.


#18

Good stuff on the guihub issue. I also added an addon comment there.


#19

Yeah noticed it, good addition. For my info, did you used the cli 3.0.0 before beta 4 and did the upload work back then?


#20

Unfortunately no. I only moved from v2 to CLI 3 at beta.4 so I don’t have any relevant information with previous v3 betas.