Unable to use Appflow for build

Hi last 4 days I am unable to build using appflow anymore. The create new build does not even load. Logged an issue with the support they are working on it forever - seems to have no interest in your pain even if you are paying for the service. On debugging using devtools this is what I see.

js.hs-scripts.com/3776657.js:5 Refused to load the script ‘https://js.hs-banner.com/3776657.js’ because it violates the following Content Security Policy directive: "script-src ‘report-sample’ ‘self’ ‘unsafe-eval’ ‘unsafe-inline’ https://browser.sentry-cdn.com https://cdn.ravenjs.com https://cdn.segment.com https://d2yyd1h5u9mauk.cloudfront.net https://dna8twue3dlxq.cloudfront.net

(anonymous) @ js.hs-scripts.com/3776657.js:5
breadcrumbs.ts:111 [Delighted] Survey not shown because person is not eligible until Fri Jan 08 2021 05:29:32 GMT-0600

As a result of this error UI seems to be not loading. Anyone faced this issue before? Urgent help will be appreciated.


We are having the same issue and have had a ticket into tech support for the past 5 days. They have told us the engineers are working on it.

We are using Chrome Version 87.0.4280.88 (Official Build) (64-bit). We have tried it on multiple platforms (windows, chromeOS, android, etc) without any luck.

  • Chris

The Appflow team is currently investigating the issue. Thanks for your patience!

In the meantime, you might try a “hard refresh” of the page - hold Shift key + click Refresh in browser (or hold command key and click Refresh on Mac).

That’s not very useful. It takes back to commit listing view

Same here and it is stilll not solved after 5 days. This is the core feature of the platform and therefore not a great experience to be honest. Also quite strange that this it’s not mentioned anywhere here: https://status.ionicframework.com/

Still not fixed. Can’t build apps since yesterday

We are now stuck with no build for almost a week.
Guys can you please rollback your changes to what was working a week ago. You must have git and tag?

Let us run our build. In the meantime you can fix your banner or analytics ja bugs , thoroughly test and redeploy blue/green.

@grabdoc In my ticket they responded that there’s a workaround. You should start the build not over the commit page but over the build page. There you can select the commit. That works for me. But still no luck on the commit page.

1 Like

I also tried just adding the package.json file a few places as a random test, but no dice.

Think they have a syntax error in their build script:

/usr/local/Cellar/ruby/2.7.2/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in require': /Users/ionic/builds/MyApp/App/fastlane/actions/build_pro_app.rb:16: syntax error, unexpected local variable or method, expecting then’ or ‘;’ or ‘\n’ (SyntaxError)
…ile.file?(‘package.json’) raise "No package.json file found …
… ^~~~~
/Users/ionic/builds/MyApp/App/fastlane/actions/build_pro_app.rb:28: syntax error, unexpected local variable or method, expecting `then’ or ‘;’ or ‘\n’
…ile.file?(‘package.json’) raise "No package.json file found …
… ^~~~~

1 Like

I received same update to ticket. Build seems to be triggered from builds page. However builds are failing with package.json not found issues as mentioned above. So it’s still unstable and I am not able to build. I will keep trying.
I will report the same back on the ticket after some more attempts.

1 Like

Yeah same here. It’s still broken.

Ditto, same problem with similar error. Successful builds from before approx 14:50 GMT then failures after that with the following errors

/usr/local/Cellar/fastlane/2.166.0/libexec/gems/fastlane-2.166.0/fastlane_core/lib/fastlane_core/ui/interface.rb:141:in `user_error!': Syntax error in build_pro_app.rb (FastlaneCore::Interface::FastlaneError)
	from /usr/local/Cellar/fastlane/2.166.0/libexec/gems/fastlane-2.166.0/fastlane_core/lib/fastlane_core/ui/ui.rb:17:in `method_missing'
	from /usr/local/Cellar/fastlane/2.166.0/libexec/gems/fastlane-2.166.0/fastlane/lib/fastlane/actions/actions_helper.rb:137:in `rescue in block in load_external_actions'
	from /usr/local/Cellar/fastlane/2.166.0/libexec/gems/fastlane-2.166.0/fastlane/lib/fastlane/actions/actions_helper.rb:129:in `block in load_external_actions'
	from /usr/local/Cellar/fastlane/2.166.0/libexec/gems/fastlane-2.166.0/fastlane/lib/fastlane/actions/actions_helper.rb:128:in `each'
	from /usr/local/Cellar/fastlane/2.166.0/libexec/gems/fastlane-2.166.0/fastlane/lib/fastlane/actions/actions_helper.rb:128:in `load_external_actions'
	from /usr/local/Cellar/fastlane/2.166.0/libexec/gems/fastlane-2.166.0/fastlane/lib/fastlane.rb:43:in `load_actions'
	from /usr/local/Cellar/fastlane/2.166.0/libexec/gems/fastlane-2.166.0/fastlane/lib/fastlane/commands_generator.rb:33:in `start'
	from /usr/local/Cellar/fastlane/2.166.0/libexec/gems/fastlane-2.166.0/fastlane/lib/fastlane/cli_tools_distributor.rb:119:in `take_off'
	from /usr/local/Cellar/fastlane/2.166.0/libexec/gems/fastlane-2.166.0/bin/fastlane:23:in `<top (required)>'
	from /usr/local/Cellar/fastlane/2.166.0/libexec/bin/fastlane:23:in `load'
	from /usr/local/Cellar/fastlane/2.166.0/libexec/bin/fastlane:23:in `<main>'
/usr/local/Cellar/ruby/2.7.2/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require': /Users/ionic/builds/matt.folkard/ucoin-client/fastlane/actions/build_pro_app.rb:16: syntax error, unexpected local variable or method, expecting `then' or ';' or '\\n' (SyntaxError)
...ile.file?('package.json') raise "No package.json file found ...

Same here yesterday was all sunshine now I got the same error:

“No package.json file found in root of project.”

So far I was not able to find any solution or workaround, need this ASAP

Just checked and debug builds for Android are back online :grin:

Yes, I can also confirm that builds are back to normal.

1 Like