Unable to execute ‘ionic cordova resources’ command


#1

I am unable to execute ‘ionic cordova resources’ command. The first time I tried it I was asked to create an Ionic account using ‘ionic signup’ command. I went through the process and was able to sign in and out from my Ionic account several times from the browser. I then returned to the command prompt and execute ‘ionic cordova resources’ command again and provided my email and password. I would then received the following error:

Request: POST https://api.ionic.io/login
Response: 404
Body:
{ message: ‘No user found by that email’,
link: null,
type: ‘NotFound’ }

Thanks


Ionic resources not working
#2

What is the URL of the dashboard that you landed on after registering?

Ionic is migrating from the legacy (apps.ionic.io) to the new Ionic Pro (dashboard.ionicjs.com) backend. Maybe switching the backend in the CLI might help so that your account matches the backend it is using.


#3

Might be you dont have ionic account.


#4

I had the same kind of issue, but mine was trying to just ionic link. As my new account was directing me to dashboard.ionicjs.com, I changed my backend to pro by using ionic config set -g backend pro and it solved my issue! Hope it works for you :slight_smile:


#5

Thanks for the response. Perhaps, I am not able to execute the command because I don’t have an Ionic Pro account. I am new to Ionic and I am just exploring it for now. I thought simply creating the most basic account in Ionic would allow me to execute the command.


#6

That is not what I am saying. I am asking you on what system you have an account. Any account should work, your CLI just has to be configure to match where you got your account. What @rdanger says should work 99%.


#7

After login into my account the URL would be https://dashboard.ionicjs.com/apps. I did try to execute ionic config set -g backend pro command and it was successful. However,I still cannot login from the command line.


#8

It’s always good work ethic to keep your ionic signed in from the CLI anyways. In my opinion at least.

Also, I don’t have Ionic pro either. I use all the free resources and I have a good bit of apps on my ionic account and I just generated my new splash screen last night.

ionic cordova generate --splash --save
ionic cordova generate --icons --save

Regards,
Neonic1


#9

Neonic1, the signup form for the old system was removed. This is why new users have these problems.


#10

@osyafriza, I suggest you contact support at http://ionicframework.com/support#support Also include a link to this topic here so they know what you already tried.


#11

Hi,

I will do that. Thanks for everyone who tried to help and provided me with suggestions. I deeply appreciate it.

Thanks,
Odon


#12

Hi,

Just to update. I was be to resolve the issue by following the instruction in

I had to revert to legacy first and then set it back to pro.

Thanks,
Odon


#13

This solution worked for me. Thank you @rdanger


#14

This doesn’t work with version 3. Any ideas please?