Unable to add ios platform


#1

I was able to build an iOS binary to deploy to the app store when I was on Ionic CLI: 2.1.15, but it wasn’t generating a 1024x1024 image needed by the app store. Mike on the slack channel suggested upgrading to the new CLI. I did that, then updated npm too and now I can’t build at all :frowning: I’m using Ionic 1. Pretty desperate for help since our company is completely stuck on trying to get push notifications deployed for our app. We’re a paying user of Ionic. Details below:

ionic cordova platform add ios

[INFO] Enabling Cordova integration.

ionic config set integrations.cordova {} --json --force
[OK] integrations.cordova set to {} in ./ionic.config.json!
cordova platform add ios --save
:heavy_multiplication_x: Running command - failed!
[ERROR] Exception: Using cordova-fetch for cordova-ios@^4.4.0

Ionic Info:

cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.13.1
ionic (Ionic CLI) : 3.13.1

global packages:

cordova (Cordova CLI) : 7.1.0 

local packages:

Cordova Platforms : ios 4.5.2
Ionic Framework   : unknown

System:

Android SDK Tools : 25.2.5
ios-deploy        : 1.9.2 
ios-sim           : 6.1.2 
Node              : v6.4.0
npm               : 5.5.1 
OS                : macOS High Sierra
Xcode             : Xcode 9.0 Build version 9A235 

Misc:

backend : pro

#2

Well, that doesn’t really matter in a community forum…

What is the exact command you are executing?
Can you remove the ios platform and then add it back?


#3

Try cordova add platform ios

drop the Ionic from the command. You can also try going to

C:\Users\user name\.ionic

and deleting config.json
Or updating Ionic. Ionic 1 is a little dusty. It says your Framework is unknown. Bad sign.


#4

The command I was using was ionic cordova platform add ios. Before upgrading the CLI (to 3) I was just doing ionic platform add ios and that worked find (with CLI 2.1.15). Now when I try just

cordova platform add I get:

Error: Source path does not exist: resources/ios/icon/icon-small@3x.png

In the past (with CLI 2.1.15) I solved that issue with

ionic resources.

Now I run ionic cordova resources but it fails with:

[ERROR] No platforms detected. Please run: ionic cordova platform add

So the platform command is failing. It’s creating platforms/ios but I don’t think it’s fully completing


#5

Is this file referred to in config.xml? Remove the line and try again.