Tel link seems not work in latest Ionic for iOS


#1

This’s quite strange result after I updated Ionic CLI and Cordova to latest version, then create a fresh project with a button that invoke following javascript statement:

window.open(‘tel:1234’);

In good result, the app will invoke phone system of that OS, for example, Android.

But now, it works for Android, not on iOS.

I check about config.xml because in ionic-v1, this problem solved with cordova’s white list plugin. But now it seems not work.

Please tried to reproduce this result. I don’t sure about iOS 11.2.1 causes it or not.

here is my config.xml:

<?xml version='1.0' encoding='utf-8'?>
<widget id="th.in.nextflow.teerasej.ionic.emergency" version="0.0.1" xmlns="http://www.w3.org/ns/widgets" xmlns:cdv="http://cordova.apache.org/ns/1.0">
    <name>Emergency</name>
    <description>An hot call app that used to make a call for emergency purpose in Thailand</description>
    <author email="john@doe.com" href="http://nextflow.in.th/">Nextflow Training</author>
    <content src="index.html" />
    <access origin="*" />
    <allow-intent href="http://*/*" />
    <allow-intent href="https://*/*" />
    <allow-intent href="tel:*" />
    <allow-intent href="sms:*" />
    <allow-intent href="mailto:*" />
    <allow-intent href="geo:*" />
    <preference name="ScrollEnabled" value="false" />
    <preference name="android-minSdkVersion" value="16" />
    <preference name="BackupWebStorage" value="none" />
    <preference name="SplashMaintainAspectRatio" value="true" />
    <preference name="FadeSplashScreenDuration" value="300" />
    <preference name="SplashShowOnlyFirstTime" value="false" />
    <preference name="SplashScreen" value="screen" />
    <preference name="SplashScreenDelay" value="3000" />
   <!--  below is just a lot of icon -->

and here is ionic info:

cli packages: (/usr/local/lib/node_modules)

    @ionic/cli-utils  : 1.19.0
    ionic (Ionic CLI) : 3.19.0

global packages:

    cordova (Cordova CLI) : 7.1.0

local packages:

    @ionic/app-scripts : 3.1.6
    Cordova Platforms  : android 6.3.0 ios 4.5.4
    Ionic Framework    : ionic-angular 3.9.2

System:

    Android SDK Tools : 25.2.5
    ios-deploy        : 1.9.2
    ios-sim           : 6.0.0
    Node              : v6.9.2
    npm               : 3.10.9
    OS                : macOS High Sierra
    Xcode             : Xcode 9.2 Build version 9C40b

Environment Variables:

    ANDROID_HOME : /Users/teerasejjiraphatchandej/Library/Android/sdk

Misc:

    backend : pro

#2

allready tried inAppBrowserPlugin?maybe that works…
Look in your logs, if its blocked by the whitelist or sth. else.


#3

Thank you. After install inAppBrowser plugin, it work!

So we cannot use just simple window.open() anymore?
It worked before recently, like suggested here