Splash Screen on Android


android is not showing the splash screen image, but iOS does. Has anybody an idea , what could be the problem?

Here is my config.xml

<preference name="webviewbounce" value="false"/> <preference name="UIWebViewBounce" value="false"/> <preference name="DisallowOverscroll" value="true"/> <preference name="BackupWebStorage" value="none"/> <preference name="SplashScreen" value="screen"/> <preference name="SplashScreenDelay" value="3000"/> <feature name="StatusBar"> <param name="ios-package" value="CDVStatusBar" onload="true"/> </feature> <platform name="ios"> <icon src="resources/ios/icon/icon.png" width="57" height="57"/> <icon src="resources/ios/icon/icon@2x.png" width="114" height="114"/> <icon src="resources/ios/icon/icon-40.png" width="40" height="40"/> <icon src="resources/ios/icon/icon-40@2x.png" width="80" height="80"/> <icon src="resources/ios/icon/icon-50.png" width="50" height="50"/> <icon src="resources/ios/icon/icon-50@2x.png" width="100" height="100"/> <icon src="resources/ios/icon/icon-60.png" width="60" height="60"/> <icon src="resources/ios/icon/icon-60@2x.png" width="120" height="120"/> <icon src="resources/ios/icon/icon-60@3x.png" width="180" height="180"/> <icon src="resources/ios/icon/icon-72.png" width="72" height="72"/> <icon src="resources/ios/icon/icon-72@2x.png" width="144" height="144"/> <icon src="resources/ios/icon/icon-76.png" width="76" height="76"/> <icon src="resources/ios/icon/icon-76@2x.png" width="152" height="152"/> <icon src="resources/ios/icon/icon-small.png" width="29" height="29"/> <icon src="resources/ios/icon/icon-small@2x.png" width="58" height="58"/> <icon src="resources/ios/icon/icon-small@3x.png" width="87" height="87"/> <splash src="resources/ios/splash/Default-568h@2x~iphone.png" width="640" height="1136"/> <splash src="resources/ios/splash/Default-667h.png" width="750" height="1334"/> <splash src="resources/ios/splash/Default-736h.png" width="1242" height="2208"/> <splash src="resources/ios/splash/Default-Landscape-736h.png" width="2208" height="1242"/> <splash src="resources/ios/splash/Default-Landscape@2x~ipad.png" width="2048" height="1536"/> <splash src="resources/ios/splash/Default-Landscape~ipad.png" width="1024" height="768"/> <splash src="resources/ios/splash/Default-Portrait@2x~ipad.png" width="1536" height="2048"/> <splash src="resources/ios/splash/Default-Portrait~ipad.png" width="768" height="1024"/> <splash src="resources/ios/splash/Default@2x~iphone.png" width="640" height="960"/> <splash src="resources/ios/splash/Default~iphone.png" width="320" height="480"/> </platform> <platform name="android"> <icon src="resources/android/icon/drawable-ldpi-icon.png" density="ldpi"/> <icon src="resources/android/icon/drawable-mdpi-icon.png" density="mdpi"/> <icon src="resources/android/icon/drawable-hdpi-icon.png" density="hdpi"/> <icon src="resources/android/icon/drawable-xhdpi-icon.png" density="xhdpi"/> <icon src="resources/android/icon/drawable-xxhdpi-icon.png" density="xxhdpi"/> <icon src="resources/android/icon/drawable-xxxhdpi-icon.png" density="xxxhdpi"/> <splash src="resources/android/splash/drawable-land-ldpi-screen.png" density="land-ldpi"/> <splash src="resources/android/splash/drawable-land-mdpi-screen.png" density="land-mdpi"/> <splash src="resources/android/splash/drawable-land-hdpi-screen.png" density="land-hdpi"/> <splash src="resources/android/splash/drawable-land-xhdpi-screen.png" density="land-xhdpi"/> <splash src="resources/android/splash/drawable-land-xxhdpi-screen.png" density="land-xxhdpi"/> <splash src="resources/android/splash/drawable-land-xxxhdpi-screen.png" density="land-xxxhdpi"/> <splash src="resources/android/splash/drawable-port-ldpi-screen.png" density="port-ldpi"/> <splash src="resources/android/splash/drawable-port-mdpi-screen.png" density="port-mdpi"/> <splash src="resources/android/splash/drawable-port-hdpi-screen.png" density="port-hdpi"/> <splash src="resources/android/splash/drawable-port-xhdpi-screen.png" density="port-xhdpi"/> <splash src="resources/android/splash/drawable-port-xxhdpi-screen.png" density="port-xxhdpi"/> <splash src="resources/android/splash/drawable-port-xxxhdpi-screen.png" density="port-xxxhdpi"/> </platform> <icon src="resources/android/icon/drawable-xhdpi-icon.png"/>

1 Like

my android is not showing,too.
Can the problem be solved?

you set the splashscreen delay to 3 seconds… maybe this is too short? And your splashscreen is gone before you see it? or your image paths are falsy

Thanks for the replay. I tried o set the delay to 30 seconds, but the effect is the same. On Android i only get a white screen instead of my splash screen.

Any other ideas?

You can explore this article may be helpful https://blog.nraboy.com/2014/08/add-splash-screen-ionicframework-project/

Yes i also tried the cordova splash screen plugin. This works.

I was just wondering what changed during the latest updates of cordova or ionic, because previously the splash screen was working without that plugin like it is on iOS.

Beside that, what i don’t like on Android is, that with the plugin the screen switches from black to splash screen to black before starting the app.

But thanks anyway for the help.

Use image with higher resolution
Icons- Min resolution 192 X 192
and Splash Screen - 2208 X 2208

Thanks for the answer. But this is exactly the resolution i use, so still no splash screen on android without the plugin org.apache.cordova.splashscreen.

1 Like

I’m having the same problem here. I used the generator from ionic@beta and I’m getting the same issue. Verified the images exist in android res folder. Not sure why they aren’t showing.

Try removing the splashscreen plugin and reinstalling it.

If that fails, do ionic platform remove android, then add it back. Then do ionic build.

Have you updated you ionic lib or CLI?

The icons and splashscreens should be in the resources folder in the root folder of your project. They copied to the res folder in the platforms/android when you do ionic build android.

Also check the android config.xml to make sure they are listed there.


Thanks, but I tried all of those to no avail. I actually just got it to work by changing the delay value. I manually hide the splashcreen, so i set it to a ridiculously high number. I guess that number was too high. Once I set it to 99999, it showed again.