[SOLVED] Help - cant get past splashscreen on emulator


#1

Hi,

my app works on the browser (ionic server) but I can’t get it to emulate it. Stucking on the splashscreen.
It did work before tho dunno why it wont work now… please help

Xcode :


#2

ok, lets go through step by step.

Have you installed the splashscreen plugin?
Have you edited your config.xml file?
Are you calling Splashscreen methods anywhere in your application?


#3

hmm… I don’t think I’m calling the Splashscreen methods anywhere… but why did it work before?

Installed Plugins:
com.ionic.keyboard 1.0.4 "Keyboard"
cordova-plugin-console 1.0.1 "Console"
cordova-plugin-device 1.0.1 "Device"
cordova-plugin-device-motion 1.1.1 "Device Motion"
cordova-plugin-device-orientation 1.0.1 "Device Orientation"
cordova-plugin-inappbrowser 1.0.1 "InAppBrowser"
cordova-plugin-splashscreen 2.1.0 "Splashscreen"
cordova-plugin-whitelist 1.0.0 “Whitelist”

my config.xml :

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<widget id="com.ionicframework.myapp892080" version="3.0" xmlns="http://www.w3.org/ns/widgets" xmlns:cdv="http://cordova.apache.org/ns/1.0">
  <name>Lashing App</name>
  <description>
        Eine Brugg Lifting App
    </description>
  <content src="index.html"/>
  <access origin="*"/>
  <preference name="webviewbounce" value="false"/>
  <preference name="UIWebViewBounce" value="false"/>
  <preference name="DisallowOverscroll" value="false"/>
  <preference name="BackupWebStorage" value="none"/>
  <preference name="AutoHideSplashScreen" value="false"/>
  <preference name="orientation" value="portrait"/>
  <preference name="SplashScreen" value="screen"/>
  <preference name="SplashScreenDelay" value="3000"/>
  <feature name="Keyboard">
      <param name="ios-package" value="CDVKeyboard" onload="true" />
  </feature>
  <feature name="Accelerometer">
    <param name="android-package" value="org.apache.cordova.AccelListener"/>
  </feature>
  <feature name="Accelerometer">
    <param name="ios-package" value="CDVAccelerometer"/>
  </feature>
  <platform name="ios">
    <icon src="resources/ios/icon/icon.png" width="57" height="57"/>
    <icon src="resources/ios/icon/icon@2x.png" width="114" height="114"/>
    <icon src="resources/ios/icon/icon-40.png" width="40" height="40"/>
    <icon src="resources/ios/icon/icon-40@2x.png" width="80" height="80"/>
    <icon src="resources/ios/icon/icon-50.png" width="50" height="50"/>
    <icon src="resources/ios/icon/icon-50@2x.png" width="100" height="100"/>
    <icon src="resources/ios/icon/icon-60.png" width="60" height="60"/>
    <icon src="resources/ios/icon/icon-60@2x.png" width="120" height="120"/>
    <icon src="resources/ios/icon/icon-60@3x.png" width="180" height="180"/>
    <icon src="resources/ios/icon/icon-72.png" width="72" height="72"/>
    <icon src="resources/ios/icon/icon-72@2x.png" width="144" height="144"/>
    <icon src="resources/ios/icon/icon-76.png" width="76" height="76"/>
    <icon src="resources/ios/icon/icon-76@2x.png" width="152" height="152"/>
    <icon src="resources/ios/icon/icon-small.png" width="29" height="29"/>
    <icon src="resources/ios/icon/icon-small@2x.png" width="58" height="58"/>
    <icon src="resources/ios/icon/icon-small@3x.png" width="87" height="87"/>
    <splash src="resources/ios/splash/Default-568h@2x~iphone.png" width="640" height="1136"/>
    <splash src="resources/ios/splash/Default-667h.png" width="750" height="1334"/>
    <splash src="resources/ios/splash/Default-736h.png" width="1242" height="2208"/>
    <splash src="resources/ios/splash/Default-Portrait@2x~ipad.png" width="1536" height="2048"/>
    <splash src="resources/ios/splash/Default-Portrait~ipad.png" width="768" height="1024"/>
    <splash src="resources/ios/splash/Default@2x~iphone.png" width="640" height="960"/>
    <splash src="resources/ios/splash/Default~iphone.png" width="320" height="480"/>
  </platform>
  <platform name="android">
    <icon src="resources/android/icon/drawable-ldpi-icon.png" density="ldpi"/>
    <icon src="resources/android/icon/drawable-mdpi-icon.png" density="mdpi"/>
    <icon src="resources/android/icon/drawable-hdpi-icon.png" density="hdpi"/>
    <icon src="resources/android/icon/drawable-xhdpi-icon.png" density="xhdpi"/>
    <icon src="resources/android/icon/drawable-xxhdpi-icon.png" density="xxhdpi"/>
    <icon src="resources/android/icon/drawable-xxxhdpi-icon.png" density="xxxhdpi"/>
    <splash src="resources/android/splash/drawable-port-ldpi-screen.png" density="port-ldpi"/>
    <splash src="resources/android/splash/drawable-port-mdpi-screen.png" density="port-mdpi"/>
    <splash src="resources/android/splash/drawable-port-hdpi-screen.png" density="port-hdpi"/>
    <splash src="resources/android/splash/drawable-port-xhdpi-screen.png" density="port-xhdpi"/>
    <splash src="resources/android/splash/drawable-port-xxhdpi-screen.png" density="port-xxhdpi"/>
    <splash src="resources/android/splash/drawable-port-xxxhdpi-screen.png" density="port-xxxhdpi"/>
  </platform>
  <icon src="resources/android/icon/drawable-xhdpi-icon.png"/>
</widget>

#4

I can’t say why it’s not working now, but usually it’s because you’ve changed a setting or aren’t calling splashscreen.hide()

Are you able to put your .run block onto a code pen or something so I can take a look, is it the default starter app?


#5

I’m only using a .run block for translating ActionsSheets on my app… I guess you don’t need that ?


#6

The problem I’m having is that I can’t see any of your code to provide a solution/answer to your problem.

Try running ionic state restore in your CLI so that you can reset your plugin settings and re-install.


#8

You are injecting $cordovaInAppBrowserProvider into your Settings Controller but never using it and then accessing cordova.InAppBrowser.open directly?

You have:
<script> function openExternal(elem) { window.open(elem.href, "_system"); return false; // Prevent execution of the default onClick handler } </script>

In your index.html? What are you trying to do here? The code pen doesn’t even work so I can’t see what you are trying to do. My advice would be to setup a default application build and run it on emulator and see if it gets passed the splash screen.


#9

Yes, I only have 2 links inside my settings.html where the inAppBrowser is loaded (settingsCtrl)

I’ve got the script in the index file here: http://www.iperform.nl/en/blog/post/cordova-open-external-link

to be honest I don’t know how to setup codepen to work like my app should work. I just put in there my code so you can see it.

If I’m doing a new blank project and emulate it, it works without any problems.


#10

Delete your platforms folder and and ionic platform add ios again - if you have xcode open close it.


#11

I’ve already tried that several times, with no luck.

is this normal looking?


#12

Is there a easy way to start a new project and import all my stuff ?

Edit:

seems like something was wrong with my config file… I just took 1 from the basic template and started it and it worked right off the bat…

thanks for you help ! @delta98