Android stuck splascreen

#1

Hello,

Working fine in local, but when i use ionic pro to build, my application is stuck on splashscreen.

Ionic:

ionic (Ionic CLI) : 4.1.1 (/usr/local/lib/node_modules/ionic)
Ionic Framework : ionic-angular 3.9.2
@ionic/app-scripts : 3.1.9

Cordova:

cordova (Cordova CLI) : 8.0.0
Cordova Platforms : none
Cordova Plugins : no whitelisted plugins (0 plugins total)

System:

NodeJS : v8.11.1 (/usr/local/bin/node)
npm : 5.10.0
OS : Linux 4.4

Config.xml :

<preference name="SplashMaintainAspectRatio" value="true" />
<preference name="FadeSplashScreenDuration" value="300" />
<preference name="SplashShowOnlyFirstTime" value="false" />
<preference name="SplashScreen" value="screen" />
<preference name="SplashScreenDelay" value="3000" />
<preference name="ShowSplashScreenSpinner" value="false" />

Cordova plugin list :

cordova-plugin-device 2.0.2 “Device”
cordova-plugin-ionic 4.1.7 “IonicCordova”
cordova-plugin-ionic-keyboard 2.0.5 “cordova-plugin-ionic-keyboard”
cordova-plugin-ionic-webview 1.1.16 “cordova-plugin-ionic-webview”
cordova-plugin-splashscreen 4.0.3 “Splashscreen”
cordova-plugin-whitelist 1.3.3 “Whitelist”

Any idea please ? :smile:

#2

When i chrome://inspect, i can see the login page without errors

#3

Hi,
I found some problems with the cordova-plugin-ionic, , try removing it.
I removed this plugin too and this type of problems vanished.

#4

OK so …

If i removed it, it works very well, but i loose auto update

If i put the last version of cordova-plugin-ionic, it works but it takes 20sec to launch, and it needs cordova-plugin-ionic-webview >=2.1.0 so i can forget android kitkat :frowning:

Well…

#5

Solved !

Last paragraph and delete “^” for cordova-plugin-ionic-webview and cordova-plugin-ionic package

Thanks Ionic Support ! Who quickly responded to my email

1 Like
#6

Per the last paragraph I am trying to update an old app via Ionic Deploy that was built with the following:

  • cordova-plugin-ionic v4.1.6
  • cordova-plugin-ionic-webview v1.1.19
  • @ionic/pro v1.0.20
  • “UPDATE_METHOD”: “auto”

but it hangs at the splash screen after the update where the previous 2 deploys worked fine.