[SOLVED] Execution failed for task ':mergeDebugResources'


#1

Hi guys,

I am developing an application with ionic 2 and I am getting the error below after run “ionic build android”

 Total time: 13.149 secs

Error: cmd: Command failed with exit code 1 Error output:
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':mergeDebugResources'.
> Error: com.android.builder.internal.aapt.AaptException: Failed to crunch file C:\TFS\aplicativos\Hibrido\gerador-argumentos-politico\projeto\platforms\androi
d\build\intermediates\exploded-aar\com.google.android.gms\play-services-base\10.2.1\res\drawable-xxhdpi-v4\common_google_signin_btn_icon_light_normal_backgroun
d.9.png into C:\TFS\aplicativos\Hibrido\gerador-argumentos-politico\projeto\platforms\android\build\intermediates\res\merged\debug\drawable-xxhdpi-v4\common_go
ogle_signin_btn_icon_light_normal_background.9.png

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

Someone know what I do? I already tried of all solution in forum ionic until now, and all solutions don’t worked for me.
Could you please help me with this?
thanks.


#2

Hello Marcos:

I have the same problem.

I am trying install googleplus auth in native mode but I get the same error.

It seem it is a problem with this plugin. Did anyone resolve the problem?

Thanks


#3

I found this problem :slight_smile:
the path had specials characters and when I executed ionic build android
I gave this error.

Another solution is copy the project to a folder in C:/project and run the build again. its works for me.

thank you :slight_smile:


#4

Thanks @marcoslcosta… it is working!!!

I was in Windows10 with “.” in the path of the repositorie.

Best regards!


#5

thanks, I just changed my path:

C:/projects/folder - copy/
to
C:/projects/foldercopy/

and it works, no whitespaces or special characters.

thanks.