Select not working on mobile


#1

Hey all!

So in the app that I’m developing we have a lengthy registration form, and the form has a few select elements, problem is, they don’t work.

I keep tapping the select element like crazy but nothing comes up, except for a few exceptions when spamming tap on the select element brings up the menu, but that happens rarely.

I’ve tried looking up the net for an answer but even if I switch the < label > tag to a < div >it doesn’t help my situation at all. I have replaced the basic arrow with another image and thought that this caused the problem but after I switched it back to the default arrow it still didN’t work so it must be something with ionic. This is my code for one of the select field:

<div class="item item-input item-select">
<div class="input-label">
Neme*
</div>
<select name="neme" id="regDataNeme" ng-model="$scope.user.neme" required>
<option></option>
<option ng-selected="adat.neme == item.id" ng-repeat="item in Nemek" ng-value="item.id">{{item.label}}</option>
</select>
</div>

Any help would be most welcome. Thanks in advance!


#2

I normally use select with ngOptions instead of ng-repeat for selects: https://docs.angularjs.org/api/ng/directive/ngOptions

Have you tried using that? There are examples at the bottom of the link.


#3

Seemingly it doesn’t fix the problem, although now I see what’s the real problem.

On iOS it works perfectly, you tap the select menu and it opens up, showing the options. However, on android, if you touch the select menu for half a second, it comes up.

Is this then an android-specific problem in ionic? Needless to say most people expect select menus to open up at a simple tap and won’t figure out you need to hold your finger on them for half a second.


#4

Are you using the android emulator or on an actual android device? If your using the android emulator in my opinion they are so hopelessly slow i wouldn’t bother, just test on an actual android device and see if you get the same problem.


#5

Testing on an android, that’s why it’s sad to see it behave like this.


#6

Hmm… not sure what it could be then :confused:


#7

Never mind, found the problem. Since I created the app at first through an ionic template, above the header area my script referred to a version set before 1.0.0 version of ionic, when I fixed it the delay was gone. Well the only problem now is that a good number of things on my app are royally messed up.

Maybe my solution will be using the old version of Ionic anyway plus using Fastclick.js, as they shouldn’t conflict on the older version.