Run Android not updating


#1

Since about an hour when running ‘cordova run android’ the app loads an older version and is not updating. I tried platform rm android and re-adding the platform. I also deleted the app of my phone many times.

Anyone know any fixes for this?

I tried cordova run ios but that one has the same problem. In ionic serve however it does show the up-to-date version.


#2

Try to remove all in www folder and then build it again


#3

When I try that and do cordova run android or cordova build android the www folder doesn’t get filled back up.

Update: Ow with ionic serve it does get filled and updated. Fixed now thanks!


#4

Try ionic cordova run android. I just tried it and build is successful and www folder has files back


#5

You should not use the cordova commands directly but always prefix them with ionic. Only then your Ionic app actually gets built as it should - otherwise your apps can contain wrong or broken Ionic builds.


#6

The normal ionic commands don’t work on my app. I always get this message, that’s why i use the cordova ones.

Sannes-MBP:buddy-NEC sann$ ionic run android
The run command has been renamed. To find out more, run:

  ionic cordova run --help


#7

You have to use ionic cordova run android instead of ionic run android