Push notification error 102 for iOS


#1

Hello,

I have a problem with an app.
Ionic push service always return me error code 102 for this App, i have two others Apps online et no problems with them.

I tried to regenerate an Apple provisionning profile and as u can see, Push notification is included.

This is an App update, the previous version worked with push notifications… now no notifications are sent…

Anyone can help with that problem ?

Thanks :wink:


#2

When i send notification :

{"errors":[],"app_id":"c2192cc6","status":"Sent","ios":{"failure_reason":"Push Error Code 102: See http://docs.ionic.io/docs/push-error-codes for more info.","success":true,"sent":1},"android":{"failure_reason":"","success":false,"sent":0}}

Invalid Token. This is most likely caused by using an invalid provisioning profile for iOS, but can also be caused by using a token that has been invalidated since the last time you’ve tried to use it.

Other Apps working but not this one… i don’t understand why and i don’t know how to debug ??

What do you mean by Invalid profile ? It seems my profile is ok.

Please help !


#3

We have the same problem.
Our iOS app v0.3 is on the store and the push notifications are still working. But if we build the app again now, even if we build the exact same v0.3 code, then that build won’t work with push. Our Android version works fine.

To try to remedy it we’ve upgraded to the new ionic-platform-web-client from the old push-client and got it working on Android. However on iOS it still doesn’t work. We get a 101 if we try and send a push to a device token we’ve had returned by a register call or a 102 if we try to send it to the userid which has an associated device token.

Our provisioning profile and push certificates are fine and have been uploaded to Ionic push, as I say the same certificates are still working with the version of the app that’s live on the store. The app asks the user for Push permissions correctly too.


#4

Hey John,

We are experiencing the same problems getting 102 errors when trying to push to iOS devices in development. A couple of iOS devices works fine just like Android. Did you find a solution for this?


#5

FYI: We forgot to add the additional iOS devices in the certificate


#6

could you solve this problem ?