Problem starting a project using ionic cli


#1

Hello guys.

The truth is that is not a problem if the version. I’m using version 1.2.7 and cordova 3.6.3-0.2.13.

executing “ionic start demodemo blank”, shows me that everything runs correctly, but I see other directories before saw. For example plugin directory and the platform.

Creating Ionic app in folder /home/julio/dev/ionicapps/demodemo based on sidemenu project

Downloading: https://github.com/driftyco/ionic-app-base/archive/master.zip
[=============================]  100%  0.0s

Downloading: https://github.com/driftyco/ionic-starter-sidemenu/archive/master.zip
[=============================]  100%  0.0s

Update config.xml
Initializing cordova project
Fetching plugin "org.apache.cordova.device" via plugin registry
Fetching plugin "org.apache.cordova.console" via plugin registry
Fetching plugin "com.ionic.keyboard" via plugin registry

Your Ionic project is ready to go! Some quick tips:

* cd into your project: $ cd demodemo

Displaying the project structure.

bower.json  config.xml  gulpfile.js  hooks/  ionic.project  package.json  scss/  www/

I have no idea what could be happening.


#2

Have you tried to run ionic platform add ios ?


#3

Ionic CLI doesn’t add the platforms by default when setting up a new project. Like @felipew said, just run ionic platform add <ios / android> and the platform specific folders for your project will be added.


#4

Hello. I use Ubuntu. I have understood that more folders are created after adding “ionic add android platform.” There is one detail that I have observed, I believe the plugins folder in the home folder, I do not understand why it should be within my project folder.

Is this normal, someone else has happened. I have installed nodejs, cordova and ionic globally with “sudo npm install -g”. This happened after upgrading ionic cli to this latest version.


#5

Ok, after reviewing what happened and that is creating these folders in my “home” folder, I found that I had a config.xml file in that directory, which had moved because I was doing some tests. I deleted the file and voila, now it works as it should. How strange to take the reference to config.xml “home” folder if the project folder is on the other hand, should not refer to the config.xml if it was in the project folder?