Cannot create Ionic project from CLI (Unable to add plugins)


#1

Hello Everyone,

I have been looking everywhere for a solution, and trust me, Ive tried everything I could. I am just trying to create an ionic project (sidemenu to be exact) but there is no way I can do that.
I am running Windows 8.1 and running that latest version of npm, cordova and ionic.
When I run the command

ionic start W sidemenu

from an Admin Cmd I get this: (I added a few lines before to show you that everything is up to date)

I have tried adding a blank project, still doesn’t work. I re-installed everything, I put the .plugman folder to not Read-Only, I’ve pretty much tried everything that I found on internet before. What’s weird is that it’s not even showing the plugin downloads, it fails before.

Hope Im clear,

Let me know if you have any idea,

Cheers,

nicnhus


#2

Remove cordova folders from your project /platform and eventually plugins then add cordova by ionic CLI: ionic platform add android and try again.


#3

I dont have any of that… Thats all there is after the command I showed before:

Thanks for replying,

nicnhus


#4

Good, so you don’t need to delete them. Now run the ionic command as suggested above. There is no local installation of cordova in this project. Then you can add plugins.


#5

I can’t do any of that… Nothing works it’s driving me crazy. So I created another app called Test, then it failed as shown before. I cd into it, try to add android platform, fails again because of config.xml so Im stuck. Here’s the full trace:

My config.xml file is empty, Idk if that’s normal. I cant create any blank app or add platforms basically.

nicnhus


#6

Your problem is the part where CLI is updating config.xml and trying to install plugins. This might be some configuration issue of your system. You can try to create project without cordova requirements by using the -w option as described in the --help of the CLI. For example ionic start -w Test and then try to add the cordova manually and also check the permissions to the folder maybe?


#7

Hey rafaellop.

Thanks a lot for helping out. After spending the night trying to understand what was going on, I finally got the answer. You were right, it was my system’s config that was the problem, tho I had no way to know. I didn’t get any error messages but when I tested my ant command I got the error: “xcopy is not recognize…” which made me realize that I didn’t have C:\Windows\System32 in my path variable. Now everything works fine :smile:

Thanks a lot,

nicnhus


#8

Great you have sorted it out. Configuration on Windows might be tricky but it is possible :slight_smile: If I may suggest something (I see you use the system cmd.exe) there’s a better way to handle the terminal stuff. Take a look: http://sourceforge.net/projects/console/


#9

That’s such a beauty!! Thanks for everything.


#10

http://learn.ionicframework.com/videos/windows-android/

Found this video very very helpful.

Sample of my PATH.

C:\Windows\System32;C:\Program Files\Java\jdk1.8.0_20\bin;C:\Program Files\nodejs;C:\Users\steveobrien_pc\AppData\Roaming\npm;C:\Program Files\adt-bundle\adt-bundle-windows-x86_64-20140702\sdk\platform-tools;C:\Program Files\adt-bundle\adt-bundle-windows-x86_64-20140702\sdk\tools;C:\Program Files\Git\bin;C:\Program Files\apache-ant-1.9.4\bin;