Onesignal using CocoaPods and Ionic1 unable to build IOS


#1

Hi guys,

I work on an older App of mine which is Ionic1. For some reason I needed to use the newer OneSignal SDK which seems working now only with CocoaPods. At first all went fine, Android works flawless but I am not able anymore to build my IOS app because of CocoaPods. I can do what I want I keep getting the following error:

ld: 72 duplicate symbols for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

I lost the entire day trying to figure this out, I tried all kind of “pod install, pod clean, pod disintegrate” etc. etc. but without any success. I also found here in this forum the post from @blakgeek and install his plugin “cordova-plugin-cocoapod-support” but keep getting the same error.

I would be happy if anybody can help me here because at this point I am pretty lost.

Thank you in advance


#2

I just ended up deleting one again my entire ios platform all changed I have done and reinstalled all.

Once done I reinstalled the onesignal plugin
changed into my /platforms/ios directory and used "pod install"
after that I added the ios platform again but forced ios4.4.0 "ionic cordova platform add ios@4.4.0"
and now all works fine in xcode and I can build and run again the app.

thankx to this issue report https://github.com/ionic-team/ionic/issues/12849#issuecomment-328472880

hope this helps also other users