Old version application not work after upgrade npm and ionic 4

hello guys.
thanks in advance for help i have a problem with my old versions ionic app
ex : ionic 3 app,
after updating my npm to latest version 8 and ionic to 4(beta) when i try to run old ionic app it gives error

angular.json not exist , even if i put it it keep saying different errors depend on what written in this file
with my experience this file is for angular 6 application and latest npm
how to run old versions on ionic , how to make local dependanices or installation for each version to have its own npm and angular-cli version any idea ! ! ?